View Full Version : AC3 - Save game won't load

01-30-2013, 12:36 AM

I was trying to load my AC3 (Xbox 360) save game and it freezes on the loading screen.

I saw there are two saves 1A and 1B. I was trying to remove 1A and load backup save 1B but didn't work.

Is my save game corrupted? Is there any way how to fix it? I had 48% progress of the game.

01-30-2013, 01:21 PM
without going into alot of things, have you tried going into System/Storage, and Clearing the Cache? i'm sure others might have some ideas, and when/if i boot the game later today, i'll see what my game save files look like.

your console is not a computer, but is....sometimes it's good to just unplug the thing for a few minutes and reboot it.


01-30-2013, 01:48 PM
I was thinking I lost my all progess but it fixed.

I reboot console, so nothing happend
... removed 1A, nothing happend
... did all thing once again, nothing happend
... started a new game on 2nd slot and do some thing from 1st mission and back to main menu and once again load my save game from 1st slot.... and it worked