PDA

View Full Version : Several Issues with AC3 regarding full sync



xAELONx
01-18-2013, 04:49 PM
Hello everyone,

I am at 90 % snyc with a lot of stuff finished but the following I am unable to finish and I would appreciate help.

I have found all fast travel stations in Boston, 10/10 but I am stuck at 84% with New York, it says that I am still
missing West New York's Underground. I wasn't lazy just coming here and popping the question, I have googled
regarding this problem. Most said this would solve itself when doing a mission in sequence 11.
Problem is, I have already finished the game when I started looking for fast travel points. On my New York map
it clearly shows that I have found 11 travel stations already but it still says 10/11. I have tried beaming from one
travel station to another hoping it could be solved like this but it didn't. Help appreciated.

2nd issue: I cannot replay Oak Island the way it is meant to be, I think. When I'm trying to use eagle vision to solve
the riddle i do not see anything, meaning the symbols do not show. It makes the sound as if they are visible to me
but they are not. Re-tried half a dozen time, always the same, do not see anything with Eagle Vision.

3rd issue (but solved) in the Encyclopedia of the Common Man I was finally able to get all my staff together but
until I did it always said I have 2/3 of farmers but at the same time it stated completed when I tried to scan them
to get the third one. What's up with that?

4th issue: In the DNA tracker it says I have zero percent of delivery quests solved when I have a completion dot
in the inventory for Lexington Items, Troy's Wood Items and West New York Items. I also recall delivering all of them,
why does it not progress in the DNA tracker?

I could probably add another 6 issues but those are the most pressing to me as I just want to finish stuff, ya know?
I'd be grateful if someone could help with those 3 open issues, appreciated.
Thanks, gang!


ae.