PDA

View Full Version : No weapons available for "Get to Vaas' Island mission. All my weapons are gone



viraxiom
01-10-2013, 08:06 PM
I spent 4 hours trying to kill that ink monster and finally did it. When I was brought to the next mission, "Get to Vaas's Island", I had no weapons and I could not melee. I tried to fast travel back to the villige so I could buy some weapons it would not allow me to fast travel. When I tried to walk to the village I couldn't because I was on a small island in the middle of nowhere. I went to Vaas's Island and tried to pick up a bad guys weapon after I killed him and the game would not allow me to pick up a weapon either. I am stuck on this level now with no weapons and no ability to take weapons. Whats the deal?

rcole_sooner
01-10-2013, 08:12 PM
So you fought the monster twice with a minion fight inbetween, right?

Then you are supposed to wake up with Citra.

I dunno.

Do you have any mods installed?

viraxiom
01-10-2013, 10:54 PM
After the monster I woke up with Citra then it went to the nest objective which was to infilterate Vaas' island but I had no weapons and I could not take any weapons from dead people...I have no mods

PablowTwo
01-11-2013, 02:00 AM
There is another thread on this subject on the forum. Some people have weapons when they start this mission, and some don't. On my first play through, I did not, but I could still do knife take downs. On my second play through, I had weapons. If you don't have weapons, it really doesn't matter, as you will suddenly have them all back after you enter the compound. You can use stealth to get into the compound without having to fight/kill anyone.

wxman57
03-24-2013, 09:56 PM
I've played through the game a dozen times or more. Going through on "Master" level now. Just killed the ink monster and left Citra's temple only to find that my weapons are gone. I appear to have 12 grenades and 12 molotovs and a knife but that's all. Swam over to Vaas' island and killed the guy on the dock but can't take his weapon. Killed the two pirates who were tormenting the girl but can't take their weapons either. Tried exiting and getting back in multiple times. Same thing. Don't think it's possible to get all the way through Vaas' compound with just a knife and a few grenades.. Tried going through the savegames and the second newest save was from 2 days ago (about 6 hrs play time) so I started back there to before I met the Doc at his mansion. That sucks.

AndyJackson2012
03-26-2013, 10:27 PM
Had the same thing happen to me on older patch. Abandoned missions and restarted, killed monster went to island and again no guns. Started over with new game and glitch was gone. I haven't had it since, either. With mine I couldn't even use the knife, so WTF?