View Full Version : Uninstalling and installing Sins Creed 3 error

01-06-2013, 02:14 AM

I have a problem with Assassins Creed 3 and is really getting me :mad:

The problem is like this: i had an ssd and a hdd mounted at my pc(the ssd is main for programs and hdd as secondary having games installed on it).After i struggled to download the game from ubisoft and with the uplay i managed to install it on the Hdd and played it for like 30 mins.All good so far.

But the problem comes now because something came up and i dont have the Hdd anymore.I was in a bit of a rush and i have forgotten to unninstall it before taking the hdd and now the game still appears in
control panel as being installed on the HDd.I tried to uninstall it, but with no luck ,it gives me an error.

As im trying again now to download the game with uplay , i cant because in Uplay it shows me that i have the game installed. I want to download the game so that i can install it on the ssd.I tried to delete the folders that were created on the ssd from the game but no luck with it.

So my problem is this , how i can install it again or download the game.
Should i use uplay from another pc and download the game there and after that copying and installing it back here?

Anyway , im opened to any advices and thank you in advance.
Sorry for my crappy english.

01-06-2013, 04:52 AM
Hello and welcome to the Forums :D
You should be able to download it again from Uplay. Check this Support Article.