View Full Version : Can't complete sequence 10 mission 1 on AC3

01-02-2013, 09:02 PM
This is the mission where you have to tackle the guard. So, I finished the game, and am now going back for optional objectives. So, I've killed the troops protecting the officers and am at the point where one of them runs away. I chased the officer, and got ahead of him. I then climbed onto the banister of the set of stairs in the same street of the guard's post, so I was above him. But, when he runs underneath and past me, the icon that displays what 'e' key does doesn't change from saying 'hang'. So whenever I try to tackle him from above, Connor just ends up hanging and looking like an idiot. I have also tried pressing 'e' again, whilst Connor is hanging, but he just drops to the ground. I have also tried to tackle him from other locations, (still from above), but I get the same result. I also checked, and I always have the option when I am level with him to tackle.

Any ideas?

01-02-2013, 09:17 PM
That is odd, you have to hold the high-profile button to tackle I think, are you sure you do that when pressing E?

01-02-2013, 10:24 PM
ok this mission is sooooo buggy, you need to stand exactly on the beam in the pathway, search youtube or the forum as there is a video showing exactly where you need to stand and tackle him, if you attempt to tackle him while hanging, it will not count.

01-04-2013, 08:48 PM
I finally got it! I rain along the banister while he was just ahead, and through blind luck, I must have pressed 'E' at just the right time and tackled him