View Full Version : How the heck do I load a save point?

12-08-2012, 02:20 AM
I finished the Dr's cave Mushroom mission and the game gave me the pirate ship "Medussa" mission, I went down the hill on foot...because my quad dissappeared....shot some goats, collected some leaves and crafted some stuff then Saved my game.

I then grabbed a water biike, I then started up the water front only to be attacked and outgunned by 2 boats, I died and now I'm at the starting village where I first woke up again???

3 questions:

WHY am I at the starting village and not on the doctors island...where I clearly saved my game and I clearly had the last checkpoint auto-saved??

And WHY is there a save game feature and not a load game feature??

How do get passed all this console nonsense and load my game from where I last saved??

the save system in this game sucks...no lie!! WHY didn't UBI (or whoever made hte game) just use a regular save system? The game would have been 10 times better!!

12-08-2012, 04:06 AM
Hi Virago and thanks for replying and trying to help.

Its kind of screwy, because if I die it just sticks me at some random "safe" location, sometimes a tower and sometimes a safe house, but if I quit to the main menu and click Story I have the choice to load game...BUT, I have 3 save sections that seem to be broken, each of the 3 sections has:

Manual save1

Manual save2

Manual save 3

BUT the only one that the game uses is section 2?? the other sections are grayed out and unuseable. AND my save doesn't load my game in the correct position I saved in....

For example just a bit ago, I cleared out a logging camp...EVERYone was dead the mision was completed and I was pretty much out of ammo, so I saved my game because I had to run to the store (real life) for my wife, came back loaded the game back up and I was in the camp BUT not outside where I saved but inside a building, so I go outside and guess what, ALL of the guys I killed got back up and started shooting at each other then at me!! LOL

This completely RUINS the game experience and I LOVE the game idea, the crafting the gunplay, but I feel I just I can't waste any more time on this if I'm going to have to do things 10 times over just because I have a life.

I wonder if my game is not installed correctly?? this cannot be the way it was designed.

does your operate this way?

anyways, thanks again for trying to help a brother out

12-08-2012, 04:47 AM
After the excellent save/load functions that were part of FC2, this save system SUCK'S like héll.

Just another feature that was working extremely well, and they chose to screw it up. I won't go into details of all the save games, I tried, but they were all for nothing since none of them ever worked. As for the three slots, we should rename them the three ****'s, because they don't work either. I only have one that is not grayed out, and regardless of where the last game was saved, every time I die, they spawn me at the foot of a tower, where no game ( except autosave ) was ever saved.

To say that this function or lack of, is actually killing the game, would be an understatement

Uncle Bob

12-08-2012, 04:55 AM
So far, FC3 seems to raise barriers, add layers of frustration, block my view with a terrible HUD, and make me squint at my computer case just to make sure it hasn't been replaced with a console.

This save system is a joke compared to Far Cry 2's. This isn't a save system, of course. It's a checkpoint system, and so far apparently a terrible one at that.

12-08-2012, 06:45 AM
It's a checkpoint system because IT'S A CONSOLE GAME!

I don't mean that remark to be rude to the players, I do mean that remark to be rude to the developers.

The three slots are used by three separate games. When you start a new game you choose which slot to use for saves, only that slot is used for that game.

There is a QuickLoad - F11 on the keyboard (F9 is Quicksave). I don't know if either works or what (manual or auto) gets saved or loaded.

When not in a mission the "Save" command in the menu appears to work and does a manual save. The menu "Continue" command appears to load a manual save, again when not in a mission. How the "Continue" command decides which save to load I don't know, possibly choosing the latest save by date/time.