PDA

View Full Version : 5.1 Channel Surround Sound Issue



shadowStalkR
12-06-2012, 01:11 AM
I'm hoping someone can help me with this because Ubisoft support is nothing short of horrible.

I have a Sound Blaster Xfi Xtreme Gamer sound card, and when I play AC3 it only comes out on 3 channels. Left, Right Front and Center.

Other games on my computer like Diablo 3 for instance, work fine with 5.1 Ch Surround.

The best advice I got from Ubisoft support? Make sure I have a DirectX-10 compatible sound card. Even though the game specs show DirectX-9 or 10 compatibility, every sound card for the last decade is DirectX compatible.

Oh, there other advice - change the sound settings in the game to stereo LOL. Not sure what the technician was thinking on this one.

Has anyone else experienced this problem or know how to fix this?

spectatorx
12-06-2012, 02:08 AM
Changing to stereo - awesome tip for someone with 5.1 configuration :D ha ha ha ha ha :D

I'm using x-fi titanium and having no problems with the game and its audio, it works nicely with my 5.1 set, sound is surround.

Good start might be updating sound card driver, here you can download it:
http://files2.europe.creative.com/manualdn/Drivers/AVP/12594/0xD5A76144/SBXF_PCDRV_WIN8_BETA_US_2_18_0015A.exe
This is the latest available beta, should work fine anyway.

shadowStalkR
12-06-2012, 07:42 AM
Great advice - thx for the link.

I tried the beta drivers (for Windows 7) and no change. Game still has sound only coming from Front Left/Right and Center Speaker only. (sub works too)

It's gotta be the game since other games on my system work just fine.

spectatorx
12-06-2012, 10:06 AM
Check your speakers setup, maybe rear speakers are not working, go to control panel, sound options and start speakers test, just to make yourself sure if everything is ok ;-)

shadowStalkR
12-06-2012, 07:09 PM
I checked all the obvious stuff - speaker setup, ran through Creative's setup prog and tested all speakers. All speakers working 100%. This was probably unnecessary though, as I have other games on the system which work fine with at least 5.1 ch, such as Diablo 3. I'm pretty sure I'm looking at a game bug, either based on driver issues or the game itself. I'm debating buying a new sound card, but it would stink to spend the money and find out it still doesn't work!

spectatorx
12-06-2012, 07:45 PM
Your sound card is awesome in games (i had it for a few days to test it :D ), there is no need to change it. If i remeber correctly card is pci and probably your motherboard has more than one pci slot so you can try to put it into another pci slot. Also you may try to completely remove x-fi driver, uplay and the game, reboot you computer and install again this new beta driver, uplay and the game.

In fact it is really weird situtation.

Intelstrangely
12-06-2012, 08:18 PM
before i upgraded my xi-fi extreme gamer to a creative recon3D i used these drivers

http://www.hardwareheaven.com/pax-download-pci-x-fi-series/218743-official-pax-master-pci-xfi-all-os-driver-suite-v2-35-default-tweak-edition.html

this is a forum that updates xi-fi drivers with permission of creative cause creative itself doesnt update there xi-fi extreme gamer drivers anymore

shadowStalkR
12-07-2012, 05:57 AM
Thanks for the tip soundjunkie1983. I tried these drivers, set up the speakers using the nifty Creative control panel for 7.1, tested them; all speakers works.

Tried the game again - no difference. Only 3.1 sound.

I've tried everything I can think of - the game just doesn't want to work with surround sound!

shadowStalkR
12-08-2012, 07:40 PM
The interesting thing is that I just bought Far Cry 3, which is also an Ubisoft game and the 5.1 ch sound works fine in this game. The requirements on the game box state a DirectX 9.0-c compatible soundcard is required versus the requirement for AC3 which states DirectX 10 compliant soundcard. Could be a red herring but might be worth it to note the difference.

rvaliati
11-21-2013, 01:57 AM
I have the same problem. Have a Creative Sound Blaster X-fi 5.1 pro. Working perfectly with all my games. Less Assassin's creed 4... Driver is updated.

Silithusa
11-21-2013, 03:58 PM
Yeah I have the same issue (only Front L&R and Center, rear speakers are mute!

I'm using a optical cable from my pc to a pioneer receiver, with realtek HD sound drivers and like I said no surround sound.
**** is annoying.
Other games like AC 3, Battlefield 3 or WoW are working just fine.

LibrlCuckSnwflk
11-23-2013, 05:57 AM
I had the same problem, and it turns out [for me at least] that AssCreed doesn't like SPDIF. I used 1/8" stereo cables for connecting my amp to my onboard Dolby of my GA-990FXA-UD3. AC4 Just came up, I had this issue, came across your thread, figured I'd offer my solution, despite how long it has been.. eh.

LibrlCuckSnwflk
11-23-2013, 05:59 AM
If you're using SPDIF, try 3x1/8" stereo connections - worked for me, and I'm still able to run my Dolby software for great sound filtering with true 5.1

ga-990fxa-ud3