View Full Version : Meatshield randomly not working?

12-03-2012, 05:44 PM
Anyone else having problem with the meatshield (I'm playing on PC with a gamepad)? Sometimes it works fine, but other times I press 'A' and nothing happens, even when I'm right next to an ordinary guard. Is there some technique to use? Seems to me like I do the exact same thing and sometimes it works and other times not.

Secondly how do you use the ropedart to reel in enemies for the meatshield? I remember seeing that in a vid before release, but I can't do it in the game.

12-03-2012, 05:49 PM
I usually get this, I have to double tap A on my Xbox and it usually works.

As for the Rope Dart, I don;t know how to do that, Or if you actually can considering how much was cut.

12-03-2012, 06:01 PM
I think I might have had the same problem before, and figured maybe my timing was off for hitting the A button (I'm a PC player with a gamepad too) but maybe I'll try double-tapping the button.

You can definitely reel in enemies using the rope dart to kill them, but I'm not sure about reeling them in just to use them as a meatshield.

12-03-2012, 06:07 PM
I think it's a timing thing or maybe they have to be in a certain position to grab them?.
Every once in awhile it hasn't worked for me either. if it's not working, I just start running so they miss me.
I use the rope dart alot for pesky guards but never for a shield - I'll try that & see what I come up with.

12-03-2012, 06:08 PM
I'm on PC and I never had a problem with it, I just hit A near an enemy and it worked every time :/

12-03-2012, 06:29 PM
Thanks guys I will do some experimenting with double tap and timing and see if I can figure it out. I have tried to find the trailer I'm talking about, but havent been able to yet.