PDA

View Full Version : Change localization/language



Kleppes
11-29-2012, 10:09 AM
So I think I figured it out, and can finally play the game.
You need to regedit a few places.
HKEY_LOCAL_MACHINE/Software/wow6432Node/Ubisoft/Far Cry 3/
Then change the Language file to English, aswel as the SKU one to US, and you should be set.
This is done on a 64 bit system, if your running 32 bit you can probably change wow6532node with just Ubisoft.

At least this did it for me.
There is also the possibility that you need to change the HKEY_CURRENT_USER/Software/Ubisoft/Far Cry 3/
Startarguement away from your native over to English, however I did not do this, and it changed it self to english after the two first changes.

Onion_Wine
11-29-2012, 03:07 PM
I just reinstalled the game, went from "Dansk" (Danish), to English. Thank god for that, because the translation was also rubbish in danish.

bobby98x
11-29-2012, 03:16 PM
I just reinstalled the game, went from "Dansk" (Danish), to English. Thank god for that, because the translation was also rubbish in danish.


What he did.

garnokglenn
11-29-2012, 06:12 PM
Thank you so much. This should be stickied, seeing how awful most translations are. The norwegian one made me cringe

Julton
11-29-2012, 06:42 PM
If you run the game from Steam you need to change the steam language from steam->settings->interface.

randomswede
12-03-2012, 12:28 AM
Thanks for the registry keys, it worked perfectly. This is a 18+ game, why would there be a need for a translation to Swedish or any Nordic language? The "translation" to Swedish is horrible, stop wasting money on translations!