PDA

View Full Version : Every 10-15 mins my PC crashes in AC3 !!



Loose500
11-27-2012, 02:20 PM
Like the title says every 10-15 mins my game crashes and I have to restart my pc I am really starting to get annoyed by this cause I really love playing this game.
My computer cant be the problem Intel core i5 and NVIDIA geforce GTX 320 and I can run the game without any problems
Anyone have a solution for this cause I really want to play without having to restart my PC all the time !!

AjinkyaParuleka
11-27-2012, 03:59 PM
Hey dude,i don't know if this works,found them when i was googling.http://www.kbmod.com/forums/rpg/some-assassins-creed-iii-fixes/ this is about crashes/fps.Also might have found an amd beta version for fps drops:http://driversnest.com/downloads/download-new-amd-radeon-driver-to-gain-performance-in-assassins-creed-iii.html.I don't have the game,would love if someone tries them out.Don't hate me if they don't work :<

Loose500
11-27-2012, 05:04 PM
I downloaded what that guy said and putted everything on max lets see what it gives , couldnt adjust the voltage it said this device is not supported

AntiChrist7
11-27-2012, 05:15 PM
Not sure if its comletly related, but i had a problems a few months back where my power supply wasnt adequatly qupportig the cooling fans. As a result the pc ran hotter than normal. When you are just browsing or typing its no problem, but once you start gaming, it will shut itself down after 5-30 mins

FourTotal
11-27-2012, 05:28 PM
virii and overheating can cause random restarts. When was the last time you went in the case and made sure the airflow was proper?

woobler87
11-27-2012, 06:10 PM
i have the same issue. i start playing and the game work for about 5 min. then the entire game freezes.
i have bought this game at uplay as a ''download'' verson.

i dont think my computer is the issue but i dont cnow,

my computer spec:

os: win 7 home premium 64 sp1

cpu: amd phenom 9850 quad-core 2500 mhz

memory: 4 gb ddr2 sdram pc2-6400

videocard: ati radeon hd 3870 x2


please help me! i really want to start play the game!

Loose500
11-27-2012, 06:17 PM
Not sure if its comletly related, but i had a problems a few months back where my power supply wasnt adequatly qupportig the cooling fans. As a result the pc ran hotter than normal. When you are just browsing or typing its no problem, but once you start gaming, it will shut itself down after 5-30 mins

Thats what im having just the problem you just said , but i installed something the guy gave me the second post and i played for a hour and dindt crash but I have to say my game runs much slower now

woobler87
11-27-2012, 07:10 PM
is it possible i having theese problems becouse a bad power suply? my bios said that my 12v vas only 11.4v?? ist this a bit low?