PDA

View Full Version : AC3 Multiplayer Servers Never Working?



AussieGuru91
11-27-2012, 03:40 AM
Hiya. Big fan of the franchise, and Ubisoft however, I've owned AC3 for a month, and not once have I been able to access to the Multiplayer because the Ubsioft servers aren't working/unavailable. Apparently there are no gamers here in Australia who've even touched the multiplayer, as well as other countries. Now according to Ubisoft Support, who re-directed me here, there is some massive problem, and nobody, U. Support included, is providing any details. This recent patch didn't fix anything. Can we please have an explanation. It would be much appreciated.

Cuzin_1t
11-27-2012, 02:49 PM
Yeah, having the same problem in South Africa still. I wouldn't be so annoyed and feel so cheated if someone would release a statement instead of ignoring the issue. Surely this is something that should be enforced by an international consumer protection act? We've paid for a product, and received only one half of what was advertised.

RexNovus
11-27-2012, 03:10 PM
Can't speak for others in my country (the Netherlands), but I can't join anything aswell. I was able to play some Wolves with a friend yesterday, but today I tried looking for a game session and couldn't find one. I tried an hour, an hour wasted of my life. My friend tried, found one instantly. I just contacted Support, see what they have to say. I''ll smack my head against the table if they point me to either this forum or the FAQ...

DTaylorSmith
11-27-2012, 03:39 PM
It's not that we can't find a game, not one Australian has even seen the Game Search Screen!!!! We've been stuck in Limited Mode due to server errors!!! And we've been there for a stupidly long time.

judson_bruno
11-27-2012, 07:54 PM
I'm having the same problem here in Brazil, the game always says that the servers is down.