PDA

View Full Version : Low FPS is NOT AMD ONLY ISSUE, Nvidia has LOW FPS as well



Maciasex
11-26-2012, 04:14 PM
I just want to point out that nvidia have the same problem with FPS as AMD.
my specs

Q9550 4.0ghz
nvidia gtx 670 @310.61

Prologue FPS: constant 60. GPU usage ~100%, CPU usage ~80%
Boston FPS: 20. GPU usage ~30%, CPU usage ~60%
1920/1200 ultra 20 FPS
800/600 low 25 FPS

erayerdogan
11-26-2012, 04:24 PM
sad but true. they wont fix it.

ace3001
11-26-2012, 04:33 PM
800/600 low 25 FPSThis is what I find unbelievable. I ran the game on a Core i3 530 + GeForce GT 520 (worst Fermi card ever) with NVIDIA driver 310.33, and easily got 30 FPS in Boston at Normal setting (the lowest setting, that is) with High textures at 1366x768.
Most FPS drops happen on the higher settings. Never at the Normal setting.

al-Assas
11-26-2012, 04:38 PM
Look at the core-by-core CPU usage. The average of the cores doesn't tell anything. It's the single largest thread that causes the CPU bottleneck.

gokaykahraman
11-26-2012, 05:03 PM
http://forums.ubi.com/showthread.php/729644-Low-Frame-Rate-In-Cities-No-Reply-From-Ubisoft-About-Patch?p=8733895&viewfull=1#post8733895

norbe09
11-26-2012, 05:08 PM
Hi everyone!

My rig specs:

I5-2500K 4.5Ghz (Custom water cooling loop for CPU)
GTX 690 at stock clocks
8Gb of ram at 1866MHz
Corsair Gold AX 1200 Watt PSU
1x Corsair 240Gb GS SSD for games
1x Corsair 120Gb GT for OS
Nvidia beta drivers 310.61

Here is what i get on Max settings.
http://i.imgur.com/mlN9Y.png
http://i.imgur.com/0Ca7D.jpg
http://i.imgur.com/bPgUo.jpg
http://i.imgur.com/56gXB.jpg

Forgot to mention in the part where i am in opera and ship i get mostly 80 to 120 FPS and in Boston city the maximum i had was 94FPS when looking into the docks but it drops to low 50s, 40s in most of the other parts of the city. Also CPU and GPU clock, temp are on idle.

Maciasex
11-26-2012, 05:46 PM
Look at the core-by-core CPU usage. The average of the cores doesn't tell anything. It's the single largest thread that causes the CPU bottleneck.
I may have exaggerated a little with GPU/CPU usage.
I cant find that place where i had drop to 20 fps. Here's a screen from Boston looking right 60 FPS/Vsync, and looking left 28FPS. CPU usage is the same, only GPU usage differs.
http://img209.imageshack.us/img209/3874/abcpi.jpg

al-Assas
11-26-2012, 07:17 PM
The point is that it's obviously a CPU bottleneck.

I think it's safe to assume that it's not well optimized. This case, with your CPU and your video card, suggests that the excessive CPU use does not happen in the graphical driver. Because the GeForce driver and the AMD driver are two different drivers. So a graphical driver update may not be able to improve the situation very much. Ubi may need to optimize their CPU use some more.

I'm a bit sceptical about that, to be honest. If they can optimize it more, why haven't they done so already before the release? I hope that they do have the willingness and the technical possibility, it's just that they simply didn't have enough time for it, and now they continue finding ways to optimize it some more.