View Full Version : AC3 Multiplayer Matchmaking or getting into game Issues / Problems

11-24-2012, 11:32 AM
Every single time when I try to access into Free for all games, it just starts new search again and again 8 times a row until I get tired (doesn't find any games). Team games however, sometimes it lets me in but gets stuck to "Loading game session"- or "Waiting for leader selection" state, so I never get to play at all. This is very frustrating because AC series are my favorite and I played lots of ACB and ACR mp, so I can't believe how AC3 mp is released like this. I can't enjoy great game if I'm not able to play.

My NAT is moderate because even though I've done almost everything I can to open it but it seems practically impossible with my router (Sierra Wireless Aircard). My uPnP available and DMZ is same as my PS3s ip-address. I've even opened those ports which AC3 and PSN uses. I've tried everything and it still doesn't get any better. In Battlefield 3 or Uncharted 3 which I also play, I get in games instantly. I'd appreciate it so much if someone could help me or they could fix it. My hopes were high when this new patch came but it didn't help.

11-24-2012, 11:37 AM
on the issue at hand try bigbond, as it has a fast internet connection and cheap, furthermore I would like to welcome you to the forums.