PDA

View Full Version : Game freezes up every 20-30 mins...



DarthSebious
11-24-2012, 02:18 AM
So like all of us on here, we wait just under a month for the PC version to be released. Yesterday I recieved my freedom edition in the post. Outstanding! So I insert the disc and start the install.

Start the game and within 20 mins, the screen completly freezes up. Alt+Tabbing just goes to a black screen. I have to ctrl/alt/delete to get out of the game. If I click on the program which is still running the game maximises and continues running (which is strange but I can still play). I've now reached about 5-6 hours into the game with it constantly doing this every 20-30 mins. It sucks but it's bareable.

Until about 10 mins ago.

I've just built the Aquila and the game starts to load the next cutscene. It then decides to freeze. ctrl/alt/delete puts me back into game but still with a white loading screen.

Now here's the really cool part. After mashing the pad in frustration, turns out that if I use eagle vision it would breifly show me part of the ship (which I'm stood on) but with basically everything bar Conner missing. I then ctrl/alt/delete out and close the game down.

I loaded back in and low and behold the game loaded me into the level fine. Wonderful I though. Well, hold your horses. Turns out that when I then go to take the wheel from the captain(which is the mission objective at that point) nothing happens. Pressing start throws me to the infinate loading screen. So yeah, 100 percent tech hang and my save game is now totally goosed after 5-6 hours of play time.

Nice one Ubisoft. Absolutely fantastic job on rushing out the PC port of this game.

Needless to say, I'm probably not going to be playing through this again and won't be buying future games in the series!

I'll watch the ending on youtube.

Cheers!

zingfharn
11-24-2012, 05:30 AM
I'll watch the ending on youtube.!

Don't watch the ending on YouTube. Make one up. I guarantee it will be better.