View Full Version : Help me please.. connecting problems Uplay

11-22-2012, 05:36 PM
Soo i have a problem connecting to uplay soo i cant play assasin's creed 3 anyone know what to do ?

Link for screenshoot : http://imgur.com/IoHF5

edit: I have tried to turn off firewall change settings in uplay nothing worked

11-22-2012, 06:01 PM
ihave the same problem as above... same screen as link..

fix this ubisoft!!!!

i bought this game today at 12 am and still cant play.. yes and i have disabled firewall&virus protection.. but nothing works.

11-22-2012, 06:04 PM
know the feeling been sitting here trying to find a solution for about 8 hours now:S

11-22-2012, 07:29 PM
I can play the game but it says the servers are down and only Ubisoft can fix that. I can't redeem any rewards because they're probably in overload right now. You should try the connection again at frequent intervals or at unpopular times to see if you might be connected.

11-22-2012, 09:07 PM
did you get it fixed crabcakelol? :)

11-23-2012, 12:47 PM
nope and it's still the same problem feels like they are never going to fix it stupid company..

11-23-2012, 01:32 PM
nope and it's still the same problem feels like they are never going to fix it stupid company..
sometimes fixes have to be done locally.

if there are ports blocked - then Ubisoft can't fix it - you have to.

Have you tried the following?


If that does not help - and you are 100% you have opened the ports required, best to speak to technical support [if you have not already]


11-23-2012, 01:55 PM
trying it right now but i dont understand what proxy name / port to enter im usaly not using proxy settings soo its just wierd that i have to do all this work to get a game that was released before it was working properly

11-23-2012, 01:58 PM
If you do not know, best to ask your ISP

You can also try:


If none work, you will need to contact Ubisoft support:


11-23-2012, 02:03 PM
thanks i havent tried it yet but i think opening these ports should fix it my router is very famous for having problems with port opening i reply onces i tried it

11-23-2012, 03:01 PM
ohh well i opened all the ports still doesnt work says i cant connect to uplay soo i guess i just have to give up

11-23-2012, 03:52 PM
ooh yeah opened all the ports aswell... dident work!!
and did the start up thing... but nothing.

and why need to open ports if they are not blocked?

and i dont use proxys to connect to internet!!

why you cant just make games that works?

dont fight against windmills!!

11-24-2012, 01:19 PM
Have you fixed the problem yet crabcakelol? I've got the exact same problem and I don't know what to doooo??

11-24-2012, 01:20 PM
everyone has this problem.... the MP is messed...

11-24-2012, 08:26 PM
hmm contact customer support... did that and get auto reply and now nothing comes after 2 days or so

just want to play AC3!!!

11-25-2012, 04:18 PM
Has anyone found a fix for this? I really wanna play AC3 NOOOWW!!!!!

11-26-2012, 05:27 PM
got reply from support...
same what i have done arlredy.. open ports bla bla bla..
it just DONT WORK!!!!!