View Full Version : AC3 The UBIsoft server is not available at this time

11-22-2012, 12:17 PM
When I want to use "additional content", it said "The UBIsoft server is not available at this time, please try again later". Then I tried multiplayer, still "not available",
the multiplayer mode became "limited mode". So what happens to the ubisoft server?

11-22-2012, 05:42 PM
Iam having the same issue, and no ****s from ubisoft were given, iam using PC btw, NO, all my ports are free, iam using NO FIREWALL at all.
Giveme one good reason for waste my money on another ubnisoft game instead of downloading it?

super X54
01-11-2013, 01:47 AM
i know its january 2013 and its still not working i am starting to get mad with them

01-13-2013, 11:43 PM
After the release of the last dlc i'm getting this A WHOLE LOT, to the point i can't even play once some days... c'mon ubisoft, how about fixing that?

03-05-2013, 08:51 AM
Try to disable Internet Connection Sharing (ICS), I found this solution of the Far Cry 3 forums and it works for me.