View Full Version : ACIII PC Patch 1.01 issues

11-22-2012, 11:17 AM
just got ACIII on PC and was super eager to play it. my excitement built during the opening cut scene and was eager to take control of Desmond if only...I couldn't. I'm hoping its just the patch but none of my controls or mouse movements work AT ALL. my system meets the requirements and is running perfectly while Desmond just stands and waits for me to do something. Please fix this soon Ubisoft. I would diagnose more problems if I could actually play it to discover them :confused:

11-22-2012, 12:31 PM
I don't see anything connecting such an issue to the patch, but this happened to me too. (Dunno whether it isn't so with the patch, cause when I got the game, the 1.01 patch was already out.)
Anyway, in my case, it was because I had a controller plugged in, and the game defaulted to that and didn't let me use the keyboard and mouse. Unplugging that got rid of the issue.
Do you have anything like that plugged in? Or an additional keyboard or mouse? Remove any such controlling devices other than the keyboard and mouse you're going to use for the game. If you don't have anything else plugged in, then it's a different issue to mine, in which case I have no idea.

11-22-2012, 12:35 PM
I have the 1.01 patch and I had no issues at all. I think it might be your controller.

11-22-2012, 02:17 PM
I do have a Razer Nostromo connected to my PC. you think disconnecting it might work?

11-22-2012, 02:32 PM
Tried it and still no cigar...any other ideas?

11-22-2012, 02:37 PM
its interesting cause i remember when I got Ghost Recon Future Soldier and a patch that was released didn't allow me to move the mouse at all. I'm assuming this patch has the same problem but it is extended to ALL controls...

Patch 1.02 is due soon I think. I read an article saying it was meant to arrive to fix any issues made by patch 1.01 any thoughts?

11-22-2012, 02:38 PM
I had to unplug my flight sim stuff (HOTAS, Pedals etc) as I was getting Xbox symbols instead of keyboard commands. Luckily I have them all in a powered hub so just one USB to disconnect rather than 7!

11-22-2012, 11:41 PM
Go in to your settings and controller, then choose keyboard and mouse. Mine was on joystick by default.

11-23-2012, 12:38 AM
Go in to your settings and controller, then choose keyboard and mouse. Mine was on joystick by default.

This. The game sets your controls automatically to controller. Actually all AC games does that.

11-23-2012, 09:53 AM
Thanks guys that helps. now i can actually play. Only problem is that the esc doesn't work. I cannot pause