View Full Version : Assassins creed 3 serial key activation problem

11-22-2012, 08:54 AM
Hello, i have an annoying problem of when i relaunch my assassins creed 3 game.

Whenever i take a break from playing AC3 and decide to relaunch it from steam, it asks for me to login into uplay and asks for a serial key. It acts as if it is going through the first time setup. However, i cant use the serial key that i used in the first place since it says it is already being used. I have tried putting it in but i got banned for doing such. Now im sitting here banned and cant even play the game even if i wasn't banned since it just asks for the serial key even though i did play it on this account that the game is registered to.

Please tell me what to do to fix this and get unbanned. I just want to play the game i bought yet, ubisoft won't allow it.

11-22-2012, 08:35 PM
Dude , I have the same problem. Played the game non- stop for like 10 hours , relaunched the UPLAY and BAM - key problem. The only difference is that I didn't got banned.

I wrote to support , so I suppose you do the same , and then we sit back and not enjoy the UPLAY....

11-22-2012, 09:56 PM
I wander if this has something to do with the intire benelux shipment being stolen (normal and join or die editions)
did they block all codes? bought my freedom edition today and can't even register it (code banned)
contacted support they asked for pic off recipe box and code but no aswer yet
hope fixt soon I want to play this game payed alot off money for it

11-23-2012, 05:50 PM
Same for me...

played normally Wednesday (just some minutes after the installation), than yesterday (Thursday) I've lunched the game, downloaded the extra contents and played... now I'm back of a bad work day... I would play and they ask me for the Key :eek:

And, sure, my key didn't work: already used

So... how can I play at my nice Assassin's Creed 3?? :mad: :rolleyes: :)

Edit 1: U.u i've try to start Ghost Recon, same problem now

Edit 2: and now it works... all alone :confused: (ok, I go play :cool:)

Edit 3: with "all alone" I woulded say that I've maked nothink... :) but perhaps that can help someone: http://ubisoft-en.custhelp.com/app/answers/detail/a_id/17015/related/1

11-23-2012, 06:57 PM
Installed the game the same day as it arrived, entered the serial (had to use CAPS to get it right :S) and then got the message saying it was 'banned'. Now support is on the case to solve it (although I think they do) and hope they reply FAST, else this is the last Ubi game I ever buy...

11-23-2012, 07:03 PM
Many people have this problem, da ****a!

11-23-2012, 09:44 PM
got the same here cant use my key because of ban.

12-01-2012, 05:03 PM
****...I have same problem today...WTF??? Uplay!! What are you doing!? I bought this game on steam....preorder it....and what I take!!!?? Why i cant play my Assassins creed 3 Deluxe Edition!!!!???
For what i've give my money!!!??