View Full Version : My Freedom Edition Unboxing

11-22-2012, 02:37 AM
Firstly, sorry, no photographs. No camera.

By goodness, Christmas has come early! Was up from 3AM in anticipation for my Freedom Edition to be arrived, watching the Australia Post tracking page. Up until 5AM, there was a lot of activity as it went from one side of the country to another. From there, it went silent, and I rocked back and forth, hoping my package hadn't fallen off the face of the planet.

At 10:44AM, it finally arrived. I watched the postman take it out of his van and walk to the door. My first impression was, "It's a bit small...". That, however, was fine when I saw what was in the package. Removing the 6 layers of EB Games "Caution: Awesome Stuff Inside!" tape, I opened the white box to reveal the Freedom Edition box. Removing the plastic wrap, I quickly had a skim over the back with all the information. Nothing I hadn't read before. I removed the cover then took off the lid. I quickly took the smaller items in the pocket of the box; Washington's Diary was much smaller than I predicted, but looked like a good read none-the-less, an envelope containing TWO awesome lithographs as the promotion said, not the EB Website, the normal game case with discs and a manual which is about 4-6 pages (it covers the controls and...nothing else), and the Steelbook case with fantastic art which I promptly put everything into so I could hide my shameful normal game case. I then unwrapped my statue, which was annoying particularly with the placement of the sticky tape on the plastic casing. The worst bit was the flag, which was separate from the statue obviously to make sure it didn't snap off in transport. The problem was the flag pole would not go into the small hole in the base properly, so it would wobble around and fall out. Eventually I was able to jam that sucker in there, and put the flag on the pole without it falling off. The statue is well detailed, but I'll make another discussion about that when I finally buy the second statue available stand-alone, "Connor: The Hunter".

At 11:06AM, I popped the discs in and ran Autorun.exe. Installation was a little painful. It was 19GBs, not 17, which is fine because I have room, but still unprecedented. I set it to install in my Steam directory (even though that itself won't make it Steamworks compatible, and it looks horrible in the Steam Library compared to my Steam Versions of all the other games). Installation got stuck on DirectX, which was most likely due to me installing the DX11.1 preview a little while ago, but installation soldiered on (a little worried if the DX install has left the DX11.1 update intact or not, but so long as the game runs fine I won't care much), until it got stuck at Sounds_SFX.forge. The disc stopped spinning so I opened the Disc's contents in explorer, and from there it continued. I was a little surprised the developers opted for 2 DVDs, when they could have used 1 Blu-Ray, although this is probably for the best as many people still don't have a blu-ray drive. Swapping the discs went without a hitch. Installation finished succesfully at 11:39AM, with no need to restart the computer, which is pleasant.

I added the non-steam shortcut to my Steam Library (linked to AssassinsCreed3.exe), and trying to avoid looking at the hideous non-steam library page, I clicked play at 11:40AM. It sprung up with the patch downloader. It finished at 11:41AM and asked if I wanted to update the game now. Obviously, I hit "Yes". At this point, it looked like it was doing nothing, the updater just sitting there. A minute later, the update installer opened. The changelog for this 1.01 patch looked tiny compared to this "Monster Patch" everyone had been talking about (I hadn't read it because of spoilers). Installation started at 11:43AM, and at 11:44AM it seemed to freeze up at about 10%, where it had no file name listed. With the cancel button grayed out, I sat patiently. Eventually it lurched forward to about 30%. Then to 40%. It sat frozen again. Then to 50%. My patience was being tested all the while. Soon a C++ Redist Updater appeared, at 11:47AM. The patch finished at 11:48AM.

Ubisoft AutoPatch was still up, which was confusing as nothing else launched. I hit the "Quit" button and hit the steam shortcut again. Uplay finally launched. I entered my CD Key normally and redeemed the life-scratcher pack with some Uplay Credits I had saved from Revelations. I took out the disc. At 11:54, I booted the game for the first time after shutting down every not required. Start up worked as all the previous games (apart from AC1). The controller was not immediatly recognised, so I had to use the keyboard to change the control scheme to my Afterglow AX.1. I reedemed both my codes, one for the Freedom Edition content, and one for the "A Dangerous Secret" as a result of the pre-order, which made me very happy. The unlocks messages were confusing as to what exactly had been unlocked, so I ignored them and look further into the settings menu. After setting the subtitles to "On" (I do it for everything so I don't miss any quiet, hard-to-hear dialogue) I set all my graphics settings to high, so I could see how good I could make the graphics look without the game lagging. I pressed the "X" button before starting to see what the "Production Details" were. This caused a black screen, but alt-tabbing to the Task Manager fixed this and after alt-tabbing back into the game I was at the main menu. I started a new game. The game got a bit framey at times, but ultimate was fine, and tweaking the AA down just a little bit fixed it.

So, there you go. This experience reminds me of when I bought Halo Reach Legenedary Edition; both times my order was changed and when it was fixed it was changed to a different version, but then staff were able to fix my order back to what it was originally. HR was $220, AC3 was $108. HR included a bigger diary, a lot more papers including a map and some pretty cool transperant X-Rays, a bigger statue and some digital content that didn't effect the game (mainly a 1-time-view documentary and a Falcon for your avatar), but looking at the cost, that's understandable. I'm happy with the game, and soon I'll be getting my season pass.

Thanks, Ubi. Now, if you'll excuse me, it's 12:36AM, I need to have a shower and lunch and then play some more AC3!

11-22-2012, 02:41 AM
Just for reference, by setting graphics to "High", I mean that I set them to the highest level possible, and my specs are as follows:

CPU: Intel Core i7 3610QM (Hyperthreaded to 8 Cores, 2.3GHz)
RAM: 8GBs DDR3 (1600MHz SDRAM)
Graphics Card: NVIDIA GeForce GT 630M (2GB DDR3 VRAM)
Storage: 750GB 5400rpm HDD
OS: Windows 7 Home Premium 64-bit

And yes, this is a laptop.