View Full Version : just installed - cannot login to uplay

11-20-2012, 08:16 PM
Installed AC3 out of the box and can't login to Uplay to register my game. Says it's down.

11-30-2012, 11:31 AM
You are so right, I got the same problem, installed out of the box and uplay cannot connect. I just want to play it.
Already tried reinstallling both Uplay and the game and blocked and turned off firewall. Nothing happens -_-

Also still awaiting reply from technical support after submitting a ticket 2 days ago.

11-30-2012, 11:52 AM
Have you anyother Uplay enabled PC titles?

If you have, do they work?

tried opening ports?


If that does not help - best to contact support - who should be able to help:

Please allow upto 48hours for a reply - the first contact maybe a simple FAQ with things for you to try, however if that does not help - please do reply and tell them that.


11-30-2012, 12:06 PM
As a matter of fact I do have other Ubisoft games installed.
Should I uninstall them?
And yes they have worked before, but I only play in offline mode and login as little as needed.

^Oh and it is nice to know that I actually got feedback^ Thanks :rolleyes:

11-30-2012, 12:21 PM

Deleting the host file worked, everyoe with same problem as jediflip and I should try this, it actually worked.
Now I better get off my Iphone internet.......

11-30-2012, 01:58 PM
What hostfile?!?!!

tell me :p