View Full Version : Frontiersman UFO challenges Glitch??!

11-11-2012, 12:42 PM
I have spent a total of 38 hours so far playing this game and i am 84% complete, however for the Frontiersman Challenge solve the mystery of the UFO I believe this aspect to have a glitch. I know from posted videos the location of the UFO and the glue I am looking for, however it is not there, there are no clues and no green circle. I have spoken to everyone I believe to be frontiersman in Boston but still no luck. Anybody got any suggestions? I really need this to be resolved.

11-11-2012, 03:40 PM


I don't know how to solve the problem/glitch, but the UFO is an umbrella in a tree if that could help you.

11-26-2012, 11:39 AM
please contact ubisoft about this, because they say it isnt a glitch.

I have the same problem going on, cant sync 100% and do not know why.

Please let me know if you found a solution.

And for all answer givers: We know its in a tree and have to search clues, however we do not have a green zone, and there is no ufo in the tree.

03-03-2013, 05:45 AM
I am having the same problem, would really like to get this fixed. 6 months is kind of a long time for something this simple to be left out of multiple updates...

03-05-2013, 08:27 PM
From UBISOFT Support

Hello ,

This issues seems to be related to a data corruption. In most cases, the corrupted file is your actual save data.

Your best option at this point is to try wiping the cache on your console's storage drive.

Clear your Xbox 360 hard drive cache (Doing so will clear title updates from the system).

1. Starting at the Xbox 360 dashboard, press the Xbox guide button
2. Scroll to the far right and choose "System Settings"
3. Choose "Storage"
4. Highlight your hard drive and press "Y" for Device Options
5. Select "Clear System Cache"

After doing this, try launching the game again and see if you run into the same problem.

If so, then unfortunately it is in-fact a savegame file corruption. There is no way for us to directly resolve this. You will need to start a new game.

If you have any further questions or concerns, please let us know and we will be glad to help.

03-05-2013, 08:27 PM
I haven't tested this myself, but if I have to start my game over, then that will really stink

03-06-2013, 02:37 PM
I'm on PS3 and have the same problem. From reading the forums, there are a lot of people with this glitch (just do a forum search). I have tried clearing my save data, like Icecannon has said, but it did not solve the problem. Everyone else I have to talked to that has tried this got the same poor result. When I sent a ticket into customer support, I received a different response:

Response Rion H. via Email 02/27/2013 05:40 PM
I sincerely apologize for any inconvenience this may have caused you.

Thank you for reporting this issue. I will be forwarded this issue up to the development team for further review. That is all I can do at this time, as we have no further information.

If any additional information becomes available, it will be detailed on the game's official forum at http://forums.ubi.com and our Support Website (http://support.ubi.com).

So at least they acknowledged the problem. Unfortunately, it also sounds like they are not going to anything about this. I don't really want to start a new save file and spend that much more time get 100% sync. All I can suggest is get as many people as you can to send in a ticket about this glitch. Ubisoft obviously does not realize how many people this affects; we have to let them know how we feel about this.