PDA

View Full Version : Assassins Creed Liberation gamebreaking bug.. PLEASE READ!!!!!!!!



Mad_Fox84
11-05-2012, 06:04 PM
I never thought I'd be saying this again after the fiasco with the animus gamebreaking bug in AC;Brotherhood but here I am AGAIN. It appears Ubisoft don't learn from their mistakes. It is frustrating, because the only time I've ever encountered a gamebreaking bug is in an assassins creed game. it's a shame because they are great games, and now I am expecting to wait atleast a month for fix, maybe longer before I can continue playing.

So here's what happened. I am on sequence 5 at the bayou. I was on the "A New recruit" sidequest, where I had to rescue a slave from some guards. I thought ti was odd initialy because I killed the guards, but the slave ran away, and I couldn't see anyway at all to stop it. I tried attacking it, doing a shoulder barge, but it just kept running.
So after trying to do it for ages, I gave up and tried to find some way to cancel it. When I restarted from a checkpoint, I ran straight for the quick travel to head back to New Orleans. I got back okay, but when I returned I kept on getting stuck on the animus (loading) screen. The first time I fell through the map and the 2nd time it just loaded continuously. So I was forced to close down the game. Both time I loaded it from my checkpoint and I was back at the bajou. I then decided to restart the memory, but now I am on the animus(loading screen) indefintely. I am currently using my slave persona, and I am unable to continue my game at all. Restarting the game does nothing. I go to "continue" and here I am STUCK on the animus.

I am really disappointed, that this has happened to me twice now. I pray to god that it doesn't happen on assassins creed 3 too. Why is it that Ubisoft continue to release games, with such horrendous game breaking bugs?

Mr_Shade, Please forward this on asap. I want to continue playing my game.

Mad_Fox84
11-05-2012, 08:34 PM
I just need some assurance that this bug is known to the devs, so I can rest easy
Thanks.

mattwillis30
11-05-2012, 10:40 PM
You arnt alone. Lots of bugs with similar results. I have personally contacted ubisoft. But I have been advised to get others that are experiencing trouble to also notify them.

Check out this forum http://forums.ubi.com/showthread.php/723533-Assassins-Creed-Liberation-save-corruption-bug