View Full Version : Sequence 6 - Mission 3 The Tea Party Bug

11-04-2012, 03:14 AM
If you haven't reached this segment of the game and don't want the experience ruined, please leave the thread.

I have just tried to replay this mission, no joke, 6 times. Each time I succeed but without 'Throwing 3 redcoats in the water - 0/3'
I have tried pushing them in. I have buried my hatchet in them and then kick them in, I have tried using only my fists to throw them in.

I always succeed in pushing or throwing them in, the numbers just don't register that I've done so and I'm getting really annoyed because I like to fully sync missions. It's just an OCD type thing, and I'm sure I'm not the only one who enjoys fully syncing missions. Can anyone help me or has this happened to anyone else? :mad::(

11-04-2012, 03:16 AM
You have to do it by countering and pressing b/circle afterwards. No other kind of "throwing" them works. One of the many badly worded achievements. It's also MUCH more likely to register if you do it by throwing them into the water that is in between the two boats.

11-04-2012, 03:38 AM
So you do it by countering then pressing B or circle near water?

11-04-2012, 03:56 AM
This is what I done and it's best to fight them on the ramps to achieve this, I got knocked into the drink a few times as well!