View Full Version : End Game Bug (SPOILERS)

11-04-2012, 01:21 AM
After Desmond died at the end of the game I did not get the achievement, which at first caught me off guard seeing that an achievement of Desmond's fate was listed. So I calmly continued to watch the credits roll thinking that the achievement would pop up after the credits. As the credits winded down I was alerted to change to disc two. Which I thought was weird because that is multiplayer. So I followed the instruction because I could do nothing else and inserted disc two. When I did, it was just the normal multiplayer hub. I then decided to go back to single player to see if it was just a small glitch. So I went to the start up screen for the game and after pushing start and choosing my save device, I was told to once again insert disc two. The same result occurred over and over again. I restarted the system and the same result happened. I am livid that I can no longer reach my save file that I have been playing for over 10 hours. Can someone please help me fix the bug so I can get my save file back. I am more annoyed of losing my save file than not getting the achievement. Thanks.

11-05-2012, 06:16 PM
Hi, please try this http://forums.ubi.com/showthread.php/721698-quot-Insert-Assassins-Creed-3-Disc-2-quot?p=8666399&viewfull=1#post8666399