View Full Version : Assassin's Creed 3 Technical Problem

11-02-2012, 05:40 PM
I purchased my preordered AC3 from Target on Tuesday and started playing it the same day. I got the day 1 patch, and at about 4 hours in I was about to start Sequence 4. Except as soon as I start the first mission and it starts loading a cutscene, it freezes. At first I thought it was my xbox overheating. So I put the game down for a few hours, then tried again . This time my save started loading right into the cutscene, and froze again. Now I thought it was the game. So on Thursday I traded it in for a new copy. Excited, I went home to try and play and it still froze. I tried for hours to get my game to load. If I push start fast enough, I can exit the memory and it loads just fine. I can do whatever available to me EXCEPT start this next mission.

I'm just about at my wits end, and I need guidance. Please help me.

11-02-2012, 05:42 PM
maybe you must push a buttons just like in AC2 when ezios father is holding baby ezio

11-02-2012, 05:44 PM
No it goes into a loading screen. The only thing I could possibly do is hold B to skip the cutscene, except it freezes before I can hold it long enough. Sucks that I can't just push a button to skip...

11-02-2012, 05:45 PM
Have you contacted Ubisoft Support?

If not, please do so asap.

Links are below!

11-02-2012, 05:46 PM
I have not, because I dind't know how. Thank you :)

11-02-2012, 06:43 PM
Any idea how long it'll take for them to reply to me?