View Full Version : Assassin's Creed 3: Stadium glitch?

11-01-2012, 11:24 PM
Hi all,

Loving the game so far but on the 'Stadium' present day segment I seem to have run into a glitch.

So, I've just crossed the catwalks. Nothing is happening! I've watched YouTube videos and know that a cutscene of a man killing a woman is supposed to begin but nothing happens. On one end there is the group of people and the guards who see me, the other the catwalks.

Is this a glitch or am I missing something.

11-01-2012, 11:44 PM
Fixed it by running back across to the other side and then running back over!

11-07-2012, 03:20 AM
tried the same going back over to the other side and trying again still not working for me.

01-19-2013, 03:56 PM
I realize this is an old thread, but I wanted to reply because nachoburgundy's solution is the only thing that's worked for me after experiencing this glitch. I even started a second playthough only to have the same glitch happen to me again! So I just wanted to check and make sure you're going back far enough to get that cutscene to play. I think the trick is going back to before the previous checkpoint, not just back over the catwalk.

When you start your game back up you'll be in front of a broken window. You came in through that opening (it's a back alleyway that let you bypass a guard checkpoint). Anyways, now have to bypass one more guard in the hallway before you go across the catwalk. You'll walk up to destroyed room where Cross is supposed to be and the cutscene still won't play. Now you have to go back the way you came, across the catwalk and down the hallway (the one guard will still be in that hallway, so don't run through so quick you alert him and have to restart). Now climb back through the broken window and go to the other side of that small alleyway. Now when you go back to the destroyed room the cutscene should trigger the way it's supposed to.

Now you might be tempted to just go back through the broken window when you first load up the game, so you don't have to actually backtrack any - but that won't work. I got this trick to work with both my playthroughs, so hopefully it'll work for you. Sorry for being long-winded, but I had other users try to help me and I was never sure if I was following instructions correctly.