View Full Version : Homestead mission - Happy Expectations still not working

11-01-2012, 01:39 AM
I assume the patch downloads automatically. I know Happy Expectations was addressed in the day one patch, but my issue is not the issue that was described as being addressed. When I play this mission and have to go defend the doctor, nobody moves. Everyone just stands around doing nothing and I am unable to interact with anyone. Did I just miss the patch or is this a new issue? Please help because building up my homestead is my favorite part!

11-01-2012, 03:39 AM
I finally got it to work by just sitting back and watching the doctor for a minute before going in and initiating the fight.

11-01-2012, 08:46 AM
its still not morking for me ive restarted it like five times and every time i ge4t close to the doctor they just stand there and do nothing

11-01-2012, 02:31 PM
The same thing is happening to my game. I've restarted and tried waiting a couple minutes as the one above had suggested. And still nothing. They all just stand there and you can't do anything. Hope there is a fix soon cause I can't do anymore Homestead Missions without this one completed.

11-01-2012, 04:50 PM
i Found a way u have to hold The manual aim button aim at a guy go behind him and press x It will choke him :) do it to every single one and it will pass hope thisw helps

11-24-2012, 05:18 PM
Well done sir...this was giving me no end of grief today - it is the MANUAL LOCKING bit that is important, without it you cannot interact with any of them.

01-05-2013, 01:32 AM
This is ridiculous! First time I played the game -on PC- I had had no problem of the short - I fist-fought the guys and everything run smoothly.
Second play-through and all of a sudden I'm encountering this very same bug you all mention here, which is finally solved by manually locking on each of the men threatening the doctor, as Saydrix12 suggested.

If I had NO problem whatsoever in the first play-through, with all the latest patches, why I am supposed to run into it now? This is pathetic! As if all the other glitches were not enough!

04-06-2020, 06:39 PM
I'm playing the remastered and the problem still exists.
I really don't understand what remastered stands for if they didn't bother to fix problems like this.

Thanks for the solution! It worked! Just did it!