View Full Version : [Spoilers] Convoy stuck on "Attacked"

10-31-2012, 11:47 AM
I'm on Sequence 6 at the moment and was playing around in my Homestead, doing the Convoy Stuff (I only have one convoy, the land one) - Anyway I sent a big shipment worth about 2,000 and it got attacked halfway. I ran to the Frontier to save it and the game froze and crashed my xbox on the loading screen - When I loaded back in the Convoy still says "attacked" but without a timer, no icon on the map and it wont clear the spot.

It's really killed my enjoyment of the game completely; I can't even do a story mission now without being annoyed due to wanting to play how I wanted to (Now I feel severely limited because of this glitch)

Do I unlock more convoys as I play or is there a fix incoming for this bug/glitch? I can't get it to clear no matter what I do and like I said; It's very much ruined my enjoyment of the game.

10-31-2012, 10:31 PM
The same thing happened to me, Convoy got attacked, I sent an assassin to deal with it and now my convoy is stuck on "attacked".

11-01-2012, 09:04 AM
My convoy got attacked too and i can't figure out any way to get it back. I haven't recruited any assassins yet. Still on sequence 5. Can someone help?

11-02-2012, 01:49 AM
I'm having the same issue on my PS3. I went to defend my convoy and after the battle the Redcoat counter still said 0/15. Yet all redcoats within the blue circle were dead. I tried fast traveling to the harbor master (as this helped with some minor glitches in the past), but after the load completed the convoy marker was gone. I returner to Homestead only to find the convoy now stuck (presumably permanently) being attacked. Luckily I still have my other two, but this severely limits my income.

11-02-2012, 02:30 PM
Same thing here.

I didnt know what i had to do when my convoy got attacked, so i figured the stuff was lost and it would reappear after some time. However the convoy is still under attack in the homestead-book, but there is no map-marker, no convoy option in my assasins meny and no timer.

I have played over 10 hours since this happened, so i dont think it will disappear by itself.


This is really annoying! Would be nice if Ubi can confirm this and say that something is beeing done. When can we expect the next bug-patch?

Im on PS3 btw


11-02-2012, 06:24 PM
Just to confirm, I still have this issue. On sequence 9 and still stuck convoy :P.

11-12-2012, 06:05 PM
I'm pretty sure Ubisoft doesn't care... but I also have this issue.

11-12-2012, 06:16 PM
I also had this issue. Multiple times in fact. Each time, after about 10 minutes, the convoy would return just fine.

12-12-2012, 03:34 AM
I too am having this problem. I couldn't find another thread and was wondering if this ever got resolved.

12-12-2012, 04:29 AM
lolol One of my convoys is on "Attacked" status for the past 5 real-time days :P

12-12-2012, 10:06 AM
i am having the same problem. i hope ubisoft will fix it soon.

12-12-2012, 10:13 AM
lolol One of my convoys is on "Attacked" status for the past 5 real-time days :P

yep i had that too. if its your first convoy, and its get attacked, its stuck there. its indeed annoying, and something that should be fixed

02-12-2013, 10:34 PM
Same here. Annoying alright!!!

02-13-2013, 05:33 PM
You can't recover your lost convoys, but you can build new convoys if you have the required materials and workers in the homestead.

02-14-2013, 02:32 PM
This bug i's reported here at least twice a week since the release of the game and the support definitely knows about it, but why isn't it fixed already? It's super annoying.

02-15-2013, 09:53 PM
Extracted from: http://forums.ubi.com/showthread.php/720981-Assassin-s-Creed-3-Single-Player-Bugs-and-Issues-Thread-*Possible-Spoilers*/page142

Without a question, the most inconvenient glitch of the game. Once the player have access to the Logbook, he can craft up to 3 Convoys, load it in the 'Trading' section of the Logbook and send it to discovered General Stores and Trading Posts. When sent, a Convoy has a calculated risk of being attacked when crossing the Frontier. If under attack, the convoy must be saved within the limited time. If exceeded, the player loses the convoy. Once lost, a Convoy can be recrafted, BUT, there's a glitch in which the Convoy remains under attack, disappearing from the Frontier and from the Assassin's Guild. Once glitched, the player permanently loses a Convoy slot. I'd advise you not to start any missions and remain outside the Frontier to be able to send recruits to save it (make sure it's 100% success rate), always paying close attention to your Newsfeed. If you're unable to reach 100% success rate or there aren't any recruits avaiable, do it yourself. And do it fast. Better safe, than sorry!

02-19-2013, 04:51 PM
Well, in my case Connor went to defend the convoy, but when he was about to kill the last two soldiers the application crashed. When launching the game again the convoy was stuck in "Attacked" state, and has remained so for the last months. I had hoped there would be a fix in the latest patch but no such luck.

03-01-2013, 01:00 AM
One of my convoys is stuck in attack as well. And for those that don't know it was not destroyed so I can't build another to replace it. It is simple stuck. Since then neither of my other convoys has been attacked.

07-05-2017, 07:23 AM
I got this game for free through Xbox live Gold, and for this I was able to fast travel to a general store, then run back and it reset, and I was able to complete it.