PDA

View Full Version : [PC] Driver San Francisco Uplay Error: Installer User Interface Mode Not Supported [Win 8]



samevo8
10-31-2012, 02:51 AM
I've Googled this problem but haven't found any fixes for my particular situation. I am trying to install Driver San Francisco via Uplay on my Windows 8 computer. However, I receive the message:

http://lh3.googleusercontent.com/--Lb4DmK1q3U/UJCDxmxEePI/AAAAAAAAF5g/3WhBrdIzma4/s428/Uplay%2520error.jpg

Has anyone experienced this issue on Uplay and fixed it?

Thanks.

Ubi-MoshiMoshi
10-31-2012, 02:22 PM
Hi, I suggest contacting Technical Support, the link is in my signature. It may be that Driver doesn't support Windows 8 and they may be able to provide a workaround.

Rodrigomansurg
11-03-2012, 02:44 AM
Go to: " C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\installers\13 "

Right click in Setup, and put Compatibility to Windows XP (Service Pack 3), it work to me!
Before uninstalling the game, I tried to open it on Uplay and he opened and closed, and gave me report the game (What shows when we closed the game) ... I'll test after installing again.

I am using Windows 8 Pro 64 bits!

T.O.R3483
12-20-2012, 08:07 PM
guys the same thing happens to me

Freebaseur
12-27-2012, 08:13 PM
+1 ! :(

The technic of Rodrigo is it ok or not ? Thanks.

guillaume1386
01-06-2013, 10:11 PM
+1 ! :(

The technic of Rodrigo is it ok or not ? Thanks.

It works for me ! :cool:

Ubi-Lhainiev
01-07-2013, 05:43 PM
Please let me know if that workaround is successful! Thank you Guillaume1386!

detno29
01-09-2013, 02:37 AM
Go to: " C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\installers\13 "

Right click in Setup, and put Compatibility to Windows XP (Service Pack 3), it work to me!
Before uninstalling the game, I tried to open it on Uplay and he opened and closed, and gave me report the game (What shows when we closed the game) ... I'll test after installing again.

I am using Windows 8 Pro 64 bits!

Hi Rod,

I tried to follow your instruction but I can not see the cache/installer path on my PC. Actually, I have already installed many games of Ubisoft. Now I am trying to install a fresh Driver San Francisco on my Windows 8 Home Pre x64 laptop. I faced the same problem with the UI mode. Any idea for me.

Cheers,

hamakazula
01-30-2013, 10:56 AM
i've googled this problem but haven't found any fixes for my particular situation. I am trying to install driver san francisco via uplay on my windows 8 computer. However, i receive the message:

http://lh3.googleusercontent.com/--lb4dmk1q3u/ujcdxmxeepi/aaaaaaaaf5g/3whbrdizma4/s428/uplay%2520error.jpg

has anyone experienced this issue on uplay and fixed it?

Thanks.

same problem, hurry the **** up and fix ubi, my fingers are itching

Ubi-Lhainiev
01-30-2013, 04:14 PM
Hi Hamakazula - For technical assistance, please create a ticket to support by clicking on the “Ask a Question” tab on the top of the page at http://support.ubi.com/

Alternatively, you may call them. You can find the Support Team in your region here: http://www.ubi.com/US/Support/InternationalSupport.aspx

Furious_Dan
03-06-2013, 09:24 PM
I'm getting tired of this s**t. Every Ubisoft game I have bought has been riddled with problems. Going to stick to Steam and Origin from now on, at least their games work.

vaseem
03-09-2013, 08:33 PM
thanks for the workaround Rodrigomansurg it worked for me on windows 8 :)

siraj2cool
03-10-2013, 08:56 AM
:cool:

jerwil9
03-29-2013, 06:49 PM
Go to: " C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\installers\13 "

Right click in Setup, and put Compatibility to Windows XP (Service Pack 3), it work to me!
Before uninstalling the game, I tried to open it on Uplay and he opened and closed, and gave me report the game (What shows when we closed the game) ... I'll test after installing again.

I am using Windows 8 Pro 64 bits!

This worked like a charm, thanks! Kind of disappointing that we need a workaround to install a modern game...

nikroJDM
04-14-2013, 10:51 PM
Go to: " C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\installers\13 "

Right click in Setup, and put Compatibility to Windows XP (Service Pack 3), it work to me!
Before uninstalling the game, I tried to open it on Uplay and he opened and closed, and gave me report the game (What shows when we closed the game) ... I'll test after installing again.

I am using Windows 8 Pro 64 bits!

^+1

matthijsv98
04-16-2013, 03:19 PM
:cool: just install in windows xp3 compatibility mode

Yes, you're right. I have windows 8. And my DVD drive is for me E:\. Open your DVD drive without run.
Then right-mouseclick on setup.exe en then properties -> the tab 'compatibility' -> check the option compatibility mode and use Windows XP (Service Pack 3) for sure.
Just click OK and you're done. It works for me :D Now you can install (:

xXx7891
04-18-2013, 09:40 AM
:cool:

Now I have to say even though XP would work, so does Windows 7!:D

Ubi-Lhainiev
04-18-2013, 03:21 PM
Great work guys! :) Thanks for updating the thread, it's very likely to help users in the future!

xXx7891
04-20-2013, 06:30 AM
Yeah I tried and I made my last message while installing but for me it doesn't work because it goes: One or more updates were found(Insert rest here) So does anyone have any other ideas? :nonchalance: :(

sami0
04-20-2013, 04:43 PM
its work me too thanks for help :)

Knotslipp
06-01-2013, 10:32 PM
Hello, i had this same problem, and i tried the solution to run in compatibility mode. However, this did not work (as it never does), and this seemed to be what people found as the solution.
I am installing the game from a CD btw.
I searched a bit more and found that it's a problem with the Windows 8 TEMP and TMP (temporary) folders.

The locations of the these folders can be configured from the Control Panel > System > Advanced > Environment Variables dialogue box.
I changed the temporary folders from:

"%USERPROFILE%\AppData\Local\Temp" and
"%USERPROFILE%\AppData\Local\Tmp" to:

"C:\Temp" and
"C:\Tmp"

This fixed my problem. Hope it helps for those of you who didn't get it working the easy way :D

Ubi-Lhainiev
06-03-2013, 03:34 PM
Thanks for updating us Qgutt! :) and glad you got it working.

Doctor_Hades
06-16-2013, 02:41 PM
I'm just reinstalling my games onto a fresh Windows 8 install and I came across this issue, which I fixed by setting the disc's setup.exe to Windows 7 compatibility. I'm amazed that we even have to do this as the game is not that old and worked fine on Windows 7 (Windows 8 is not that different) but that's Ubisoft for you, I guess. :rolleyes:

Damilolao
08-08-2013, 04:57 PM
I have it working on Windows 8. All you need to do is locate the Driver sf installer in downloads and right click on it. Then click on properties and change the compatibility to windows 7. Then run it as normal and it should work

Thunderbird64
09-27-2013, 11:15 PM
no need to make a ticket or call them just put compability to windows xp service pack 3 works like a charm on windows 8 pro
C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\cache\installers\13\setup.exe

sudeep123456
09-30-2013, 06:45 PM
open up command prompt on win8
You can open up the location where the setup.exe is found and then,
say if its in E Drive
then type
E:
now it would have entered E drive. Type setup.exe -i GUI

E:\> setup.exe -i GUI

this will help you out i guess.

Although this works fine, it will start the installation process on windows 8, but I couldn't finish the entire installation. since there were some errors during the installation process at the end. And I couldn't launch the game. I was asked to download an update patch for the game but that too has to be run in the same way as told before from the command prompt. Finally I couldn't run the game which is totally insane.

ezra01
10-10-2013, 12:57 PM
yeah windows xp compatibility mode saves the day again

GeovaniCavalari
11-18-2013, 03:44 AM
I've Googled this problem but haven't found any fixes for my particular situation. I am trying to install Driver San Francisco via Uplay on my Windows 8 computer. However, I receive the message:

http://lh3.googleusercontent.com/--Lb4DmK1q3U/UJCDxmxEePI/AAAAAAAAF5g/3WhBrdIzma4/s428/Uplay%2520error.jpg

Has anyone experienced this issue on Uplay and fixed it?

Thanks.
I have the solution, if you use windows 8 just go in the game folder right click on the icon with the title autorun> click Properties> click the Compatibility tab, and change the compatibility mode for windows 7, is ready just install normally.

S.A.Killer
11-19-2013, 08:15 AM
I've Googled this problem but haven't found any fixes for my particular situation. I am trying to install Driver San Francisco via Uplay on my Windows 8 computer. However, I receive the message:

http://lh3.googleusercontent.com/--Lb4DmK1q3U/UJCDxmxEePI/AAAAAAAAF5g/3WhBrdIzma4/s428/Uplay%2520error.jpg

Has anyone experienced this issue on Uplay and fixed it?

Thanks.

I have experienced the same problem on windows 8 , what you do is: open the cd or image and right click on installer(setup or installer) then properties, and compatibility , change it to (run in windows 7) and run as administrator and the program will install..Killer_sa1.....enjoy.

parabol1134
11-20-2013, 04:45 AM
if you are having problems installing Driver San Fran after the download AKA install just crashes and nothing happens ect fallow these instructions

1. go to username\AppData\Local\Temp\DriverSF\Disk1\InstDat a\

then there should be zipped files in there resource1 part1-8 and a setup

2. right click setup and go to properties and compatibility put it in windows XP SP3 and make sure you click run as admin as well

this will fix your problem I have windows 8.1 and this worked for me and you will have to go in and do the same compatibility for the game exe file where ever you installed it. After it is installed so it will run.

arindamxxx
12-07-2013, 12:15 PM
Run UPlay on compatibility mode for windows 7.

Jos_ku
12-20-2013, 10:00 PM
This video shows pretty well how to install Driver SF on win 8.
I haven't made this video.

http://www.youtube.com/watch?v=GN7toDpC3yc

- ubiE7F0.tmp may not the same as the video (my file ubiFDE5.tmp)
- File DOESN'T appear in the folder if you don't run the game after installation
- I have only one problem: appears on the display window and it says "choose another location, where the installation program extract"

Not anymore, because:
1. Run the game after installation
2. Download update
3. Install it in Win 7 compatible mode
4. Now the game should be work

yoman200134
01-14-2014, 07:36 PM
I Fixed it fast Everyhting you have to do is these things
1. Find "Setup.exe"
2. Right Click it
3. Go to Compitability
4. Change the Compitability to Windows 7
5. HIt "USE" Down in the right corner
6. Run the Setup.exe again
7. Play and enjoy the game

Josefwa123
06-01-2014, 07:16 PM
Hi there,

The way to do this is to open up a Command Prompt (type in "cmd" in the Start menu), navigate to the setup folder using "cd (NAME_FOLDER)" and running the setup using "setup.exe -i GUI". Hope this helps. :)

WiZz-
01-16-2015, 09:15 PM
Please let me know if that workaround is successful! Thank you Guillaume1386!

I followed Rodrigomansurg's instructions and worked for me, game has now installed. I set to Win XP Service Pack 3 and then double clicked setup from that directory and it worked. If you try clicking on retry or install through Uplay, it still will not work so do it through the game directory. Hope that helps

rockalance
05-23-2015, 10:31 PM
I tried the command line trick before i searched and it did install. but the update it needed couldn't find the installation. I had to go and set every exe in the folder and subfolders in compatibility mode for xp sp3.

kevindcruz
06-17-2015, 09:26 AM
Hi Rod,

I tried to follow your instruction but I can not see the cache/installer path on my PC. Actually, I have already installed many games of Ubisoft. Now I am trying to install a fresh Driver San Francisco on my Windows 8 Home Pre x64 laptop. I faced the same problem with the UI mode. Any idea for me.

Cheers,

dude..he's right.. it worked for me.. even i had the same issue.. do this..if there's autorun right click then troubleshoot compatibility,first it will select win 7 as default compatability mode , then choose it worked previously in win xp . now it will run the program in win xp mode and it should work.. cheers

Linus 159
10-12-2015, 04:16 PM
Ubisoft / Uplay is the worst f***** **** i ever have used, pls let all games be at steam! :)

Leefie
10-31-2016, 07:17 PM
I've Googled this problem but haven't found any fixes for my particular situation. I am trying to install Driver San Francisco via Uplay on my Windows 8 computer. However, I receive the message:

http://lh3.googleusercontent.com/--Lb4DmK1q3U/UJCDxmxEePI/AAAAAAAAF5g/3WhBrdIzma4/s428/Uplay%2520error.jpg

Has anyone experienced this issue on Uplay and fixed it?

Thanks.

I copied the disk contents to my desktop and ran setup directly in Win 7 compatible mode..
Worked for me.

bakhtjs
03-07-2017, 07:00 PM
I've Googled this problem but haven't found any fixes for my particular situation. I am trying to install Driver San Francisco via Uplay on my Windows 8 computer. However, I receive the message:

http://lh3.googleusercontent.com/--Lb4DmK1q3U/UJCDxmxEePI/AAAAAAAAF5g/3WhBrdIzma4/s428/Uplay%2520error.jpg

Has anyone experienced this issue on Uplay and fixed it?

Thanks.

For UI Problem;
In the command window [Activate by SHIFT+RightClick and selecting CommandPromptHere in your Setup.exe folder]
type "setup.exe -i GUI" without quotation marks in command line (Dos mode). This is surely going to work.

bakhtjs
03-07-2017, 07:02 PM
Ubisoft / Uplay is the worst f***** **** i ever have used, pls let all games be at steam! :)

For UI Problem;
In the command window [Activate by SHIFT+RightClick and selecting CommandPromptHere in your Setup.exe folder]
type "setup.exe -i GUI" without quotation marks in command line (Dos mode). This is surely going to work.