View Full Version : ACBSP.exe has stopped working

10-25-2012, 04:49 AM

I just bought AC:Brotherhood and after playing 3 minutes of it, the game crashed, I tryed to run it again but now the game doesn't even STARTS.

I've searched on the forums and looked for the solutions but none of them have worked for me.

Please I need help with this, this is starting to piss me off......
I believe that it's not from hardware site because we are talking about a 1.5k pc.

11-01-2012, 12:20 AM
Bought this on Steam recently, played it once for a few hours with no problems, come back to it a few days later and it won't even start...

I've uninstalled and re-installed about 5 times, tried the make a SAVED file 'fix' and nothing fixes it.

I'm using my own rig and it's more than capable of running the best AAA titles at max settings and my drivers are all up to date as far as I know.

This is my first time using Ubisoft's Uplay launcher and so far I can tell you I am not impressed at all.

11-01-2012, 03:03 AM

This could be a Region Specific Issue and sometimes Patches are specific to each Region.
Please try the following steps-

Uninstall the game
Reinstall and allow the game to auto-update

Please make sure you install the game to the default location given during install to avoid any mix up with the Patches.

If this still does not solve your issue, you need to contact Ubisoft Support directly. You can follow the links in my signature.