View Full Version : Unable To Find Ubisoft Game Launcher

10-05-2012, 06:43 PM
That's all it says when I try to launch Assassin's Creed: Brotherhood. I used to be able to play it just fine. Just now noticed this yesterday. I thought it might've been the disk permissions repair that I ran the other day. I tried reinstalling and that didn't work. I tried restoring from backup and that didn't work. I tried repairing disk permissions again and that didn't work. Went digging around and found the game launcher myself and tried opening it manually. But, all it said was please try launching the game you want to play instead.


That's the message that I get every time I try to launch the game. I don't really know what else to say, other than it's been working fine up until...well, yesterday was the first time I had noticed it, but it had been a few days or even a week or so since the last time I played the game. And, Assassin's Creed 2 still runs just fine. :)

10-05-2012, 07:07 PM
its best if u contact support - http://support.ubisoft.com/