PDA

View Full Version : Minimum Requirements for Assassin's Creed III



evil9494
09-26-2012, 12:01 AM
OFFICIAL http://ubisoft.custhelp.com/app/answers/detail/a_id/17133/p/88,2511
Minimum System Requirements

Supported OS: Windows Vista (SP2) / Windows 7 (SP1) / Windows 8
Processor: 2.66 GHz Intel Core2 Duo E6700 or 3.00 GHz AMD Athlon 64 X2 6000+ or better recommended
RAM: 2 GB (4 GB recommended)
Video Card: 512 MB DirectX 9.0c-compliant with Shader Model 4.0 or higher (see supported list)*
Sound Card: DirectX 9.0c-compliant (5.1 surround sound recommended)
DVD-ROM: Dual-layer drive
Hard Drive Space: 17 GB
Peripherals Supported: Windows-compatible keyboard, mouse, optional controller (Xbox 360 Controller for Windows recommended)
Multiplayer: 256 kbps or faster broadband connection

Supported Video Cards at Time of Release:
AMD Radeon HD 3870 / 4000 / 5000 / 6000 / 7000 series or better
NVIDIA GeForce 8600 GT / 9 / 100 / 200 / 300 / 400 / 500 / 600 series or better

BBALive
09-26-2012, 01:47 AM
Pretty close to the rumoured minimum required specs.

Jexx21
09-26-2012, 02:21 AM
I'm ..5 GHz behind the minimum system requirements..

:(

ProletariatPleb
09-26-2012, 02:23 AM
Spill your beans Ubisoft, where is DirectX11?

dex3108BL
09-26-2012, 02:42 AM
This specs are wrong. They say that Win XP is not supported but they say that DX9 card is minimum. Win Vista and higher OS is working only on DX10 and DX11 cards. Also DX9 cards don't have Shade 4.0, they have 3.0 Max and DX10 and DX11 are supporting Shaded 4.0

Jexx21
09-26-2012, 02:51 AM
Also, the processor up there is the same one that they show for ACB and ACR max settings, which I can run just fine on my Intel Core 2 Duo 2.13 GHz E6420, so I should be able to run AC3 fine.

ProletariatPleb
09-26-2012, 02:53 AM
This specs are wrong. They say that Win XP is not supported but they say that DX9 card is minimum. Win Vista and higher OS is working only on DX10 and DX11 cards. Also DX9 cards don't have Shade 4.0, they have 3.0 Max and DX10 and DX11 are supporting Shaded 4.0
Well that Shader part is odd...the OS thing is not an issue.

rileypoole1234
09-26-2012, 03:12 AM
Probably should be in the PC Forums but anyway I'm glad I'll be able to run it on my PC after I play it multiple times on PS3. That doesn't really make any sense but it gives me an excuse to play AC3 as many times as possible.

Will_Lucky
09-26-2012, 04:25 AM
This specs are wrong. They say that Win XP is not supported but they say that DX9 card is minimum. Win Vista and higher OS is working only on DX10 and DX11 cards. Also DX9 cards don't have Shade 4.0, they have 3.0 Max and DX10 and DX11 are supporting Shaded 4.0

No actually, sounds about right. XP Support is dead this year therefore games will stop supporting it more or less as of next year.

AnthonyA85
09-26-2012, 05:00 AM
Well, CPU wise, I MIGHT be ok, i'm using a Q6600 2.4 GHz and i can run all AC games on pretty much maxed out settings (apart from multi-sampling, i keep that on low/normal)

RAM wise I'm good, GPU, i'm getting an upgrade soon so that's taken care of, though i am suprised DX11 isn't there, hopefully these specs will be amended.

And this should be in the PC forum

anik_lc
09-26-2012, 06:03 AM
Its all OK for me. I should be jumping all the time till release cause I expected the requirement to be much higher.

dex3108BL
09-26-2012, 06:30 AM
Well lets see. If game doesn't support Windows XP only logical reason is because it uses DX10 or higher. If game supports DX9 i don't see why Windows XP is not supported. And if Shader 4.0 is minimum DX9 card is not an option because Shader 4.0 cards are DX10 or higher.


So i would like to ask Shade, Widow or UbiGabe to check with devs what are real requirements.

Locopells
09-26-2012, 08:50 AM
Well this is spectacular - I'm fine!

And this should be here:

http://forums.ubi.com/forumdisplay.php/195-Assassin-s-Creed-General-Discussion-%28PC%29

keep your eyes open for it being moved.

ProletariatPleb
09-26-2012, 08:55 AM
No actually, sounds about right. XP Support is dead this year therefore games will stop supporting it more or less as of next year.
No it's not right, DX9 has SM3.0, not 4.0 and the game needs 4.0..which means atleast DX10 card. XP is dead, that isn't what he's pointing out.

anik_lc
09-26-2012, 09:19 AM
Well this is spectacular - I'm fine!

And this should be here:

http://forums.ubi.com/forumdisplay.php/195-Assassin-s-Creed-General-Discussion-(PC) (http://forums.ubi.com/forumdisplay.php/195-Assassin-s-Creed-General-Discussion-%28PC%29)

keep your eyes open for it being moved.

I guess he realize that the PC section is quite dead. :p

Locopells
09-26-2012, 09:31 AM
Yeah, I know - just giving a heads up.

MT4K
09-26-2012, 10:39 AM
It has been posted as a sticky thread in the PC section by a Forum Manager ;).