View Full Version : AC not working on my system

09-02-2012, 10:04 PM
Hi all I'm new to this website and to this game.

My niece gave me this game last Christmas as a gift. I tried to load it on my gaming system (Windows 7 64bit) last yr but It didn't work,for what reason i don't remember why. Anyway I've loaded it today and all I'm getting is a blank blk screen but i hear the game starting. I've tried to get the updates and all I've found is 1.3. I think I need 1.0 but I cant find it anywhere. I would be very grateful if someone could help out:)

Thanks TwoToe

09-03-2012, 04:01 AM
Which AC? The first one?

09-03-2012, 01:37 PM
Yes,I believe so

09-03-2012, 02:00 PM
Hi There,

Please contact Ubisoft Support - They will be able to direct you to any patches you may require.

It does seem odd that you get a blank screen though, since patches normally fix minor issues, not major ones such as that - it maybe a graphic driver issue - or something else.

I don't think it's due to being a lap top - but just in case, some laptop cards are not supported by the game, however Support should be able to advise you further.

It would be useful to tell them the exact name of the game though, since there has been a few.

Support can be contacted via the links in my signature.

09-03-2012, 02:45 PM
I'm not running a laptop. My rig is a desktop,Q9550,ep45-UD3P,GTX-570,4g ram,Win7 64bit. The game is assassin creed ,I think its the first one. I tried to d/load the update 1.3 but it didn't load.it said i need 1.0. I got it to load on my other rid which was older and it had XP 32bit OS. I've read that its will work with Win7 so im not realy sure whats going onI didn't really play any because it wasn't my gaming rig.