View Full Version : Lost Archive DLC missing

08-15-2012, 04:53 PM
So I installed the Lost Archive DLC but it isn't in the menu. How can I solve this problem?

08-15-2012, 06:43 PM
I think you have to enter one of the portals on Animus Island.
Enter into your desired profile, walk over to the Desmond's Journey portals, and one of the last ones should be the DLC.

08-15-2012, 07:27 PM
No. It should be in the main menu. I tried the portals anyway and played through one desmond sequence (because it's the same style), but nothing... I guess that's wasted money...

08-15-2012, 07:56 PM
Have you tried this?
"I believe you have to go under "Extras" in the main menu. There should be a place to enter your DLC codes."

08-16-2012, 03:19 AM
I'm having the exact same problem, after two months of constantly e-mailing the customer support, I got a new code, but it wasn't working either...I guess I wasted my money too.

08-16-2012, 08:13 AM
Do I have to enter the code? According to the support ( http://ubisoft-en.custhelp.com/app/answers/detail/a_id/16436/p/88%2C2366 ), the code is only for the bonus skins etc but I already have those from E3...

08-16-2012, 09:12 AM
I entered the code and now it works! They should have said that on the support...

08-16-2012, 04:53 PM
I entered the code from the beginning, and got the message that everything included in the DLC is now unlocked, the ones included in the multiplayer like the Ottoman Doctor and the badges, skins are actually there, however, the singleplayer based bonuses aren't in the game, even though I do get an exclamation point near the Invetory button, as if a new item was added, there's nothing there(Altair's robe, for example).Plus, I don't have The Lost Archive tab in the main menu, there's only Story mode, Multiplayer, Options, Extras and Exit to Windows.Any clue on what to do?

08-16-2012, 08:03 PM
Have you installed all the patches appart from ading the code to the extras section of the game's menu?

08-16-2012, 09:04 PM
Yeah, my game is updated with all the patches, and I entered actually two codes in the extras section, both having the same result, still not getting what I paid for.

08-17-2012, 07:40 AM
I suggest that you ask support.

08-17-2012, 01:20 PM
That's what I did for the past couple of months, they offered me a new code, but it's not working either.
I actually got the first 2 DLCs too and haven't got any problems with them, I really have no idea why this is happening.

08-19-2012, 02:56 PM
Today i got AC:R and there was a two codes one for single player and other for mp dlc,but they not working,when i enter it says invalid,what the hell ?