View Full Version : AC2 Savegames still dont work / Bring me to a random previous point.

07-21-2012, 04:21 PM

So, bought this game just before previous weekend when there was supposedly a bug with Uplay, or the server didnt work correctly..
Either way the game didnt save properly or not at all and I lost a wackload of time on my free weekend, my first weekend i had actually free in ages.

Now since ubisoft said it was fixed, it still doesnt work :s . The problem I have now is that when I boot the game I go to a random spot in the game where i have been before.

I was ready to go to Venice for instance. I reboot the game and Ezio is in his pre-assassin garb. I reboot the game again and I am at the spot where Medici tells Ezio he fell in the Arno and Giovanni saved him. etc etc.

At some point I got past that bit (or so I thought) and reached the point where Ezio receives the Medici cloak and is able to go to Venice. Well... when I rebooted just now I was back at the villa back when you go there for the first time....and Mario wants to teach me some swordfighting.

So... when is this going to work?? please??
I am pretty sure my internet connection and my PC are NOT the blame for this, everything else, including AC:Brotherhood have just run fine in the past.

Dont tell me to turn of the Uplay cloud, in my desperation I tried that and what happens next is that I have to start from scratch again. I am NOT going to do that.

So how to fix this? Ubi??


Just tried to log in again. Now I can get that stupid cloak again.... how can this be so random??

07-21-2012, 06:18 PM
I have this issue too. I've contacted technical support twice since Monday, but nobody has gotten back to me.

07-21-2012, 06:51 PM
No word from Ubisoft. I'm sure they appreciate having our money though... VERY unprofessional, basically telling the customers to go f*** themselves.

07-22-2012, 07:21 AM
Disable Cloud Saves In settings In Uplay.

07-22-2012, 06:11 PM
Razzak, I appreciate people posting and helping, but what is the point of you posting when you havent read my post at all?

I said that I was NOT going to disable the cloud because then I have to start from scratch again, loosing all the time i spend.
Besides that, Ubisoft should fix the service they provided and for which we paid.

Hopefully we get a reply from ubisoft....

07-22-2012, 10:20 PM
To fix this you need to wait around 3-5 minutes between running Uplay and game itself, each time you close Uplay. You can actually disable cloud sync and keep your progress. But you need to do it after allowing Uplay to sync proper files. So run Uplay, wait 3-5 minutes, run game, leave immediately, disable cloud sync and run again.

07-22-2012, 10:32 PM
Alright, so due to the cloud save utterly failing and people assuming we haven't tried reaching real support over this with no luck at all (yo its the weekend they can't do anything when they aren't there), I've come up with an easy temp solution that will not restore your game but will allow you to continually play through your game without having to deal with this, and its really easy! It just takes a moment.

So, apparently your saved files are stored in C:\\program files(x86)\Ubisoft\Ubisoft game launcher\save games\long *** folder name\4

It'll have like save 1 through 25 and the meta saves + whatnot. What you do, is make a folder on your desktop or somewhere easy to access, copy and paste the files into that folder whenever you have finished playing (without closing out of it, just make sure you go to say the main menu before doing this and then ALT TAB)

Now, when you start up you will have your saves backed up. Just enter into your origin for saves file (that 4 folder), delete everything, and then copy and paste the saved files from that folder you made on your desktop, into that 4 folder annnnd then start it up without cloud sync enabled, you'll get into your game just fine and be able to continue your progress without hating ubisoft.

Once again, my client does not allow me to actually save data, this works. It also makes sense. Though it does suck that you might have to do this each and every time but hey, to be able to play the game, it's not so bad. It is an enjoyable one.

Hope this helps everyone.

07-22-2012, 10:54 PM
Please make sure you all do contact Ubisoft Support and let them know the details. Every Ticket helps give them more detail about an issue. You can follow the links in my signature.
Thanks ;)

07-23-2012, 01:04 AM
Good post Every_Ginger, that's actually what I also thought about doing myself - if/when I continue playing. Right now I'm still so disappointed and annoyed by this, I'll need to take a little break :D

07-23-2012, 04:45 AM
This is crap... There probably are more then enough tickets that they know they have serous problems with UPLAY. People all over the forum have posted various problems and haven't gotten any help. I played the game for over 5 hours yesterday... The best I can hope for is 2 hours from my last mission. This is crap this is a poor way to run a game. I alreay had Altair's uniform I spend 3 hours going to all the **** tombs and doing all the puzzles.. had like 6 sections of the number 16's puzzle .. back to 4 and 3 hours from the uniform... the cloud save is broken the uplay is broken there is nothing online that this game should be required to be online to play. Fix you stuff Ubi or lose another customer.


07-24-2012, 04:44 PM
Small personal update to share:

Last week after making this post I did what Black_widow9 suggest and informed their technical support.
The answer I got was: "just diable the cloud".

Only thing I could do was reply that the answer given for my (and many others') problem was not satisfactory.

The amount of hours I lost while using the cloud service is hours and hours, probably a few days at this point. Starting over without Cloud sync would not only mean that I lost all the time spend, but also that I have to redo all that time to get to the point where I was. Furthermore: having done all segments a zillion times now, the enjoyment factor to redo the first bits has been lost in me completely.

Ubisoft is a big company, and I understand that some problems can't be fixed 'on the fly' so to speak, but Uplay seems to be a fairly integral part of your games. It strikes me as really strange that the best thing you can come up with is: "dont use it then".
Please ubisoft, if thats the best you can come up with: dont market Uplay on the box of the DVD I bought, or patch AC2 so that when I actually want to play it Uplay doesnt start at all, but I go right to the game.

I want it working, or not at all. thats my point.

Still waiting on a solution / fix Ubi !!!!


07-25-2012, 11:26 AM
Ubisoft is a big company, and I understand that some problems can't be fixed 'on the fly' so to speak, but Uplay seems to be a fairly integral part of your games. It strikes me as really strange that the best thing you can come up with is: "dont use it then".

My thoughts exactly... I urge each and every one of you to think twice before again supporting a company that treats their customers like this. A lot people disliked Ubisoft because of the Uplay DRM to begin with, though it never really bothered me before. But the way they've handled this (or to be precise - haven't handled), what in my opinion is a major issue, really left a sour taste in my mouth.

07-25-2012, 12:19 PM
I am experiencing the exact same thing for the second time now. The first time it happened I just decided I'll suck it up and started to play the game from scratch. The second time round playing the game I put alot of extra effort into the game sucj as upgrades to the Villa and in fact had it upgraded to the max. Then it happened now for the second time. I don't foresee myself playing the game again for a third time. I tried the copy paste scenario from the save game folder but still gets placed and random spots I've been in the game earlier. I will therefor now just cease to play the game in its totality. What a waste of time, money and energy.

07-25-2012, 03:31 PM
Ok, i'll start off by saying that this is a solution someone else sugested, and might not work for everyone, but i've tried it and it's worked so far, I too have been experiencing random save loads during my second playthrough, lost entire sequences of progress the other night.

When you start up Uplay DO NOT immediately start the game, instead, WAIT 3 - 5 minutes, this should give the Uplay client enough time to synch with the online saves, this approach has worked for me so far.

07-27-2012, 12:56 PM
I bought the whole set during the Steam sale and after playing a long time I shut the game down. The next day I loaded the game and was set back 6 hours of play time.
I shut the game down right away before doing anything that would write a new save then disabled the cloud. When I loaded my game again I was right at the point I was supposed to be at.
It seems like the game saves two copies of your saves. One on your comp and one at ubi's servers via the cloud. It looks for the cloud one first so if that saved incorrectly then you'll get an old save. If you turn off the cloud it'll revert to the save on your comp which is the newest (provided you don't save after being sent back in time).
After turning off the cloud and getting my proper save back I didn't have any problems through the rest of the game.
Now if only Brotherhood wasn't a slideshow on my comp that crushes the recommended specs.