View Full Version : Can't Unlock Auditore Crypt in AC2

06-08-2012, 05:00 AM
I just bought AC2 through steam and i bought all the in-game unlocks but when i got to Sequence 5 the Auditore Crypt was not available. The Altair outfit and knife belt upgrade work fine.

I noticed that the Crypt is being offered for free during E3 so could that be causing the unlock to be bugged?

06-08-2012, 04:39 PM

Has anyone else unlocked the Crypt during the E3 promo?

06-09-2012, 07:10 PM
I have the same problem.
I was worried that the crypt can only be unlocked at sequence 5 (I'm currently at seq.7). Knives and altair's outfit work fine but crypt doesn't work. Hope it's bug and it will be fixed soon.

06-10-2012, 10:27 PM
same here , this should get fixed...

06-11-2012, 09:20 PM
Same problem here!! Does anyone know how to fix this?
Some people with the same problem just log out the uplay accout, and log in again and the problem was fixed, but i tried this method and doesn't work :(!

06-12-2012, 02:46 AM
its fixed for me!

06-12-2012, 08:21 PM
its fixed for me!

how did you fix it??

06-12-2012, 08:29 PM
MY PROBLEM WAS JUST FIXED!! Thank you Ubisoft :D

06-14-2012, 06:43 PM
I experienced this before, but my problem has been solved

12-24-2012, 12:44 AM
Now I'm having that problem. I redeemed it a few days ago and have completed sequence 10. At the villia it tells me I need to use uplay to unlock the tomb (no icon on map).
Have exited and re-started game several times.
Have rebooted computer.
Tried logging out and back into uplay.
Checked uplay in game (says I have it redeemed but still no access).

12-27-2012, 09:03 PM
Having the same problem.

12-28-2012, 04:57 AM
I also have tried all the suggestions found and am still locked out of the family crypt. I think it might be a server problem on Ubisoft's side. Or they have to reset something in bugged accounts.

Anyway, I'll keep trying and searching for a while as I really want this added content.

12-28-2012, 02:43 PM
I have the same problem too. Also I have the Battle of Forli and The Bonfire of the Vanities DLC but still all the Templar Lairs isn't available. How can I fix that?

01-02-2013, 07:50 AM
I have the same issue. I have unlocked this reward through Uplay and yet it isn't unlocked in the game. If anyone from Ubisoft monitors these threads, please help.

01-02-2013, 11:41 AM
The auditore crypt is a small puzzle that you go through and learn about Ezio grand or great grandfather's life. It's nothing grand really!

01-03-2013, 02:51 PM
I've got the same problem. I redeemed the reward during the holidays special, for 20 U, but when I get to the crypt in Monteriggioni, it says Uplay required or something like that.
I have completely finished the game, I tried logging in and out, but it keeps telling me to unlock through Uplay.
I really hope it will be fixed soon, I want to see the crypt...

01-03-2013, 05:14 PM
I have the same issue myself. E-mailed Ubisoft Support and all I got was:

I have reported this issue to the AC team for review.
I will respond here once I have an update on the situation.

Thanks for your patience.

A lot of people seem to be having this issue, but I suppose because AC2 is now considered old and irrelevant, Ubisoft is slower to offer support for it. :rolleyes: When a new game in a series comes out, it brings in new players to play it, and if they like it, they may jump back to play the older games. I know I dabbled with AC3, enjoyed it, wanted to see what all the fuss was about with the other games and so went back to play those before really diving into AC3.

Since I made my ticket (December 28th), I finished AC2 with no sight of the crypt unlocking and moved onto Brotherhood. Almost done with that now, too, and about to move to Revelations. Still want my Auditore Family Crypt. It's all I need for 100% Sync in AC2.