View Full Version : "ACRSP has stopped working" possible solution?!?!

04-14-2012, 08:46 AM
so ive been having this problem for 2 months where i cant play the game because i get a crash that say ACRSP has stopped working, i have tried formatting, new drivers for everything and tried all the suggestions on every site i can find on this issue and nothing, Well today a friend of mine came over and we wanted to play Revelations online but it keeps crashing so we tried logging on to his UBI account and it finally worked perfectly and he says he never plays the single player, Apparently if your playing single player campaign then whenever the game saves if it got corrupted you will get this error and has nothing to do with your system or the game itself its UBI's Game Synchronization that saves your games that makes this crash occur and unfortunately theirs no way to delete your saved games and if there is i would like to know! I'm contacting UBI and tell them to either delete my saved games so i can play the game or a new CD Key cause for $60 i shouldn't be going through this. And if you guys don't believe me if your getting this crash right after you launch the game then have a friend that has the game working good sign on to his account on your PC and you'll see.:mad:

04-14-2012, 09:16 PM
Hello and welcome to the Forums :D
Do you have the correct Patch installed? Please check this post-
Fix for RU version of Assassin's Creed Revelations Patch 3 Russian Territories (http://forums.ubi.com/showthread.php/661225)