View Full Version : Ac revelations factions not working

03-24-2012, 10:53 PM
Hi can anyone help!!! Xbox 360

I've asked the tech guys and they just gave me bull about making sure my consol is well ventilated and that the cache was cleared etc I tried all that but my console is working fine anyway. I've seen others asking this elsewhere but i am getting desperate to finish my game at 100% and can't carry on right now without a fix??

The empty hand B is not working when trying to get hired factions to do their job. I can hire them but when I try to send them to distract or engage guards all I am able to do is get them to follow or stop. I am 100% complete in everything so far and only have the last 2 memories to complete so I want to complete all the side missions before continuing and I simply cannot get the correct B ****on to work. This is very frustrating and I have seen posts from other players online complaining of the same situation. I have also tried locking on to the guards i want to get my faction to distract but it makes no difference. Can you please take a look at this as I will be really disappointed if I cannot get 100% on everything after investing many enjoyable hours up to this point. If it helps at all on the first thieve one when I hire the group using B there is for just a second the message on the HUD to distract but it then just vanishes as soon as it has appeared and I'm stuck with stop or follow ggggrrrrr! Please tell me you can fix this with an update and save me from the severe disappointment I am feeling right now!?


03-24-2012, 11:07 PM
You have to use the left trigger on xbox to highlight your target then press B. Should work then!

03-24-2012, 11:13 PM
left trigger to lock on then B when your close enough to stun 'em :D hope that helped

03-25-2012, 12:05 AM
left trigger to lock on then B when your close enough to stun 'em :D hope that helped

did you even READ his post

03-25-2012, 12:29 AM
You have to have them close by and you have to have locked onto the desired target. If the group is too far away from you, you won't be able to send it after the target.