PDA

View Full Version : Assassin's Creed-Poor Perfromance



Rixanu
03-19-2012, 11:15 PM
I posted this over on the Steam forums, figured I'd post it here as well. I'd really love to fix this problem if possible.

I recently purchased Assassin's Creed and I've been having some major performance issues with it. When I max the game out, I get an average of roughly 10 FPS. I was hoping that my relatively new computer could run a 5 year old game decently, but I can't seem to get decent performance. Even more moderate settings get me about 20 FPS. For comparison, I can run Bioshock 2, a roughly 2 year old game, maxed out at around 30-60 FPS. I have switchable graphics, with both games set up to use the discrete GPU. Switching exclusively to the discrete GPU yields no difference in performance. Any help would be greatly appreciated.

My specs:
HP Pavilion dv6-6135dx Laptop
Windows 7 Home Premium x64 (SP1)
AMD A8-3500M Processor
6GB RAM
AMD Radeon HD 6750M discrete GPU
AMD Radeon HD 6620G integrated GPU

SixKeys
03-19-2012, 11:36 PM
That does sound strange. I would recommend contacting Ubisoft support.

Rixanu
03-21-2012, 03:28 PM
So, support tells me that laptop graphics cards are not officially supported. Shows what I get for not reading the fine print. I really don't want this game to be a waste of $20, so if anyone has any tips that might get this game working properly on my computer, I would be forever grateful. So far, I've tried installing the latest AMD drivers, but that didn't exactly work.

spectatorx
03-21-2012, 04:26 PM
In AMD Vision Engine Control Centre set antialiasing to "controlled by application". What game settings do you use? I'm asking about resolution, details, shadows, antialias etc. Try to disable in-game antialiasing also.

Rixanu
03-21-2012, 04:38 PM
Well, I've pretty much been playing with the lowest possible settings to get a decent framerate. I've already got AA set to "controlled by application".

Shadows 1/3
PostFX Off
Resolution 1366x768 60hz
Vertical Sync Off
Graphic Quality 1/4
Multisampling 1/3
Brightness 5/10
Level of Detail 1/4

That makes the game playable, but it obviously looks like crap. I just have this feeling that the game is not utilizing my card properly, as I can play games like Bioshock 2 and Portal 2 maxed out with little issues-and those are both fairly new games. Assassin's Creed came out in '07. It's just bugging me that my computer can't seem to handle a much older game.

Mr_Shade
03-21-2012, 06:26 PM
Well, I've pretty much been playing with the lowest possible settings to get a decent framerate. I've already got AA set to "controlled by application".

Shadows 1/3
PostFX Off
Resolution 1366x768 60hz
Vertical Sync Off
Graphic Quality 1/4
Multisampling 1/3
Brightness 5/10
Level of Detail 1/4

That makes the game playable, but it obviously looks like crap. I just have this feeling that the game is not utilizing my card properly, as I can play games like Bioshock 2 and Portal 2 maxed out with little issues-and those are both fairly new games. Assassin's Creed came out in '07. It's just bugging me that my computer can't seem to handle a much older game.


Have you tried using the different DX version .EXE in the install folder?

You should have a DX9 and DX10 version of the .EXE in the install folder - try DX9 - since it may have defaulted to using the DX10 one - which will be a resource hog.


If your using the DX9 one, try the other one, just in case ;)

Rixanu
03-21-2012, 06:58 PM
Wow, that helped a lot. I maxed out the settings, and DX10 gave me about 10 FPS while DX9 gave me about 20. I still feel as though I should be able to run the game better than 20 FPS, given my performance with newer games. Maybe I'm just grasping at straws, I don't know. But this was certainly a step in the right direction. If in the end I can't gracefully max it out, I can at least play it with higher than the lowest settings (probably). Thanks a ton for the tip!

spectatorx
03-21-2012, 07:15 PM
Install available updates in control panel/windows update, update soundcard drivers too. This also might help a little. IMO you should to try to reinstall your windows but it's last thing you should to do.

Rixanu
03-21-2012, 10:29 PM
Funny story, I just reinstalled Windows last week. Everything is up to date as far as I know. =/

spectatorx
03-21-2012, 10:32 PM
So that's very weird, the game should run smoothly on your machine. I give up and have no more tips for you.

Rixanu
03-21-2012, 10:36 PM
Well, that's unfortunate. Thanks for trying, though! :)

spectatorx
03-21-2012, 10:45 PM
You may try latest, pre-certified driver 12.3, maybe this will help or may make performance worse xD If this driver will decrease performance you always can to revert elder driver ;-)
http://downloads.guru3d.com/AMD-Catalyst-12.3-RC-Driver-download-2858.html

Rixanu
03-21-2012, 11:15 PM
It looks as though the only things that need upgrading, according to the installer, are the SDK Runtime, the Steady Video Plugin, and the Vision Engine Control Center. The graphics driver itself is still up to date. Is upgrading any of these components really going to help performance? Sorry, I just really don't like to mess with drivers unless I have to.

spectatorx
03-21-2012, 11:23 PM
I had installed 12.2 in installer of these showed to me there is no need to update the driver but it updated and now i have 12.3 version. Just try it, in worst case you will just rollback 12.2, it is not a problem when you have an installer of these on your laptop ;-)

Rixanu
03-22-2012, 01:00 AM
Long story short: that didn't work and I'm never doing it again. For some reason the Control Center wouldn't recognize my card, but the card itself was still working. It didn't help with the game.