PDA

View Full Version : Assassin's Creed Brotherhood Multiplayer not working anymore?



steryman_007
03-02-2012, 12:57 PM
Today I bought Assassin's Creed Brotherhood, becuase I wanted to play the multiplayer(I also have Revelations) but when I've entered the game, pressed enter on multiplayer, waited a bit and said it couldn't connect to ubisoft servers. Are the Brotherhood multiplayer servers closed?

WTW26
03-02-2012, 04:30 PM
I played a few matches today.

steryman_007
03-02-2012, 05:42 PM
About how many hours ago? I got the game about 5 hours ago... Does it work now? Because mine still doesn't. I've tried to reinstall the game, repatch it, relog, anything :( Tried also installing on another windows, another partition...

WTW26
03-02-2012, 07:01 PM
Just tried it again. Works fine for me.

steryman_007
03-02-2012, 07:13 PM
It seems it's from the account... Asked my friend to enter on his account and check if he can access multiplayer, he told me he can, so I've logged in on his computer but I wasn't able to play. Please how can I fix that?

BurntToast0
03-03-2012, 04:31 AM
Im in the same boat.

I just took AC brotherhood for ps3 in to EB games for a trade and money down to get it for PC and Im getting errors login into multiplayer. Same error OP is getting. Im thinking it might be something to do with Uplay? Ive used this "account" for my PS3 version.

Is there a fix for this? Whats the problem?

steryman_007
03-03-2012, 11:41 AM
It's working now... didn't made anything.. it's just working :D Maybe they helped me(I've told them at ubisoft support that it's account related). I hope it will work fine for you too :) I wish you luck.

Venge1975
03-03-2012, 07:36 PM
Brotherhood's MP is fine.. just takes a while to get thrown in to session at times.