View Full Version : Log in failed! Assassin's Creed Revelations

02-24-2012, 08:46 AM
Just bought assassin's creed revelations, made a new uplay account that is working perfectly fine on here, but trying to log into uplay in the Assassin's Creed Revelations launcher
isn't working! An orange box appears that says, "Log in Failed! You need to log in at least once before playing offline. If you have logged in on this computer before, check your username/password."
Any help is much appreciated! really want to et on and play ASAP lol :)

02-24-2012, 09:03 AM
I am experiencing the same problem.
What is going on???
I can't even play offline.

02-24-2012, 09:36 AM
My assassin's creed2 can't play too,Perhaps because of same problems.
UBI:'You have just paid for this game now? HaHa! We don't allow you play this game yet!'

UBI think All PCgamers are game robber so they checking our PC and our payment proof.
No proof No game for us.But perhaps the real robber playing the game Now .
Screw it.

02-24-2012, 11:57 AM
seems to be working now

02-24-2012, 10:57 PM
Glad you got it sorted. ;) If you have any further issues please make sure you contact Ubisoft Support. The link is in my signature.

02-25-2012, 12:20 AM
Are you looking into it?

03-24-2012, 03:19 PM
How did you deal with it? mine still doesnt work. Im a big fan of the assassin's creed series, and im just dying to play ACR.

03-31-2012, 03:40 AM
i have same problem! how do you resolved it?

04-03-2012, 10:17 AM
Please help, I am having the same problem I have also changed my password twice and for some reason i cannot even play Brotherhood as it tells me to log in...??!!??... Also when it does a update the update is 500mb (is that normal?) and it does not complete the update...

05-31-2012, 11:10 AM
I need help with this, how did you fix it?

05-31-2012, 12:16 PM
same problem. hurry to fix up servers, dear ubis, plz

06-01-2012, 09:06 AM
i have same problem! how do you resolved it?

06-01-2012, 02:05 PM
In settings set offline mode off.

06-01-2012, 06:31 PM
same problem here..it's not only that I can't play ACR Multiplayer..I can't even play offline! do something please

06-03-2012, 10:03 PM
This is crazy-I see tons of people having the same issues? But no answers. I am having the same issue and it would be greatly appreciated, if someone could reply with an answer. Just sucks to have paid for the game, took all the time to download. Took all the time to get an account. And then tried all night log to trouble shoot the issue. So much time wasted???? All I want to do is play This game. Please can anybody post a fix. If I find a fix, I will repost my fix. Come on guys-There has to be a simple solution??? I just can not figure it out.
(You need log in online at least once before playing offline. if you looged in on before check your username \ password) ----I have logged on online-but can't find a way to play---over and over again????????????HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!

06-04-2012, 09:23 PM
I am getting the same error message that everybody else is on login. "You need to log in at least once before playing offline. If you have logged in on this computer before, check your username/password." I've tried changing to settings to turn offline mode off. Doesn't work. This is really stupid. How do I resolve this?

06-05-2012, 08:01 PM
ok i have waited a lot.. i bought using my steam wallet.. and its been over a month since i added the cash to the wallet and the game still wont login.. i can login throught my ps3 on driver san Francisco
but not on ac:r on steam...

really looking for a solution

06-13-2012, 05:22 PM
How should I do

06-13-2012, 06:09 PM
If you have log in issues, please contact Ubisoft support - links are in my signature.

06-28-2012, 03:48 PM
this is useless just bought it and it doesnt work, good job ubisoft