View Full Version : IL-2 - 1946 Doesn't instal (Connection timeout)l [Steam]

01-14-2012, 10:25 PM
I bought IL-2 Sturmovik: 1946 during a sale that Steam had in December.
I am not able to install the game because an error message comes out: An error ocurred while installing IL-2: Sturmovik: 1946 (Connection timeout)

I contacted Ubisoft Support, and they told that it was Steam's issue, and that i had to contact Steam Support. Well i did, they gave me some stuff that i could do, but that didn't work, and they told me if that couldn't work, that i had to contact Ubisoft.

Here i am, i'm not the only one having this same issue as you can see: http://forums.steampowered.com/forums/showthread.php?t=2350131
Some people could solve it but i tried all solutions i've seen and the problem still persists.
I don't know if anybody uses Steam here, i'd be very thankful if you can help.

01-15-2012, 04:32 AM
I don't think this is in the right section, i'd really appreciate if it gets moved.

01-15-2012, 06:02 AM
You are probably in as good a place as any to ask about this - but I don't see how Ubisoft can really help anyway. Downloading is Steam's concern, not Ubi's - until the software is downloaded, there isn't much they can do about it. About the only software issue that I can think of that might be a problem is if you are running Vista or Win 7, and are installing IL-2 in the default location - this can cause problems, so you are better off creating a new folder, and installing IL-2 there. It might possible help to run the installation while in 'administrator' mode too. Frankly though, if Steam are trying to pass the buck to Ubi over this, I'd ask for a refund, and get a DVD version instead - it is dirt cheap these days. Again, don't install in the default location, and you'll need to patch it to get the latest additions - though these are all well worth the trouble.

01-17-2012, 10:50 PM
I installed the 4.11 patch into the folder that the game should be, then i tried to install the game and its downloading now. I hope it finishes soon.

01-18-2012, 12:32 AM
Glad you finally got the download to work.

It is possible the download will overwrite the patch, or at least parts of it - you may have to apply it again afterwards. You'll be able to see what version you have on the startup screen (bottom left corner, in red) If all is well, it should say 4.11.