View Full Version : AC Brotherhood flying machine control lockup...?

12-30-2011, 08:21 PM
So I'm on Da Vinci's flying bomber mission. Once I'm in the bomber, the controls seem to completely lock up. I can't turn at all. I can see Ezio lean back and forth in the thing, so I know the controls are registering... but I can't turn the plane or control the pitch. Launching bombs works fine.

Occasionally, pausing and then returning to the game seems to reset the controls and I can turn for a couple seconds, but then it stops working again. I always just fly off the map helplessly.

Here's a link to another forum where people had the same issue.
http://www.gamefaqs.com/boards...brotherhood/58618928 (http://www.gamefaqs.com/boards/996094-assassins-creed-brotherhood/58618928)

Any advice?

07-21-2012, 11:22 AM
I've played this game through several times and never encountered this bug. But I recently installed the game and now this is happening. I upgraded my computer and installed Win7 64-bit since the last time I played it, I don't know if that has anything to do with it. It's like the physics of the bomber mission is not working right. As the above poster says, you can see Ezio lean left and right when you are trying to turn, but the bomber won't turn. The bomber often does'nt lose height the way it should and sometimes just comes to a stop in mid air and hovers. Alt-Tab'ing and going to desktop and back sometimes gives me maneuverability back but never for long enough to make any progress.

No one has found a workaround for this at all?

It's extremely frustrating.


07-21-2012, 11:36 PM
Try turning v-sync on. I've always been able to get through that mission without messing with v-sync but it is definitely bugged and the controls get sluggish and not very responsive as the mission progresses.

07-23-2012, 09:20 PM
I tried it with v-sync on and it definitely improves the situation, far fewer "control lock ups". Still happens sometimes and you have to alt-tab out once or twice to regain control and suffer some uncontrolable flying off the map. But at least it's doable now, thanks for the tip.


12-30-2015, 05:58 PM
For anyone still having issues with this like I just was. Change your game resolution to be at 60 hertz. Once I changed to 1080p 60 hertz from 144 hertz the controls worked perfectly again.!

01-02-2017, 12:07 PM
So I ran into this same bug where I was unable to steer left and right at all. So Annoying!! In order to fix it, I had to cap my frames at 60 FPS and cap it at 60 Hz using a third party program called riva statistics tuner. There are all kinds of ways to cap your FPS (just google FPS capper lol). This fixed the problem and allowed for me to steer left and right. Hope this helps anyone in the future who is stuck on this annoying bug.

03-06-2017, 03:27 PM
I sometimes can steer the flying machine without problem for a while, sometimes it just goes straight and won't turn right/left at the beginning. I'm running this on a Win7 64bit laptop, and I've checked that 60hz is already set. It's really frustrating, after I spent hours already and cannot finish it.

03-06-2017, 03:51 PM
have you turned vsync on in settings?

07-14-2017, 06:23 PM
I experienced this issue as well, but it was relatively easy to fix for me. Primary cause seems to be the use of a high refresh rate monitor. Make sure to set the following when going through this mission:

- In settings: set resolution to your whatever is your monitor's resolution, at 60Hz
- In settings: set V-Sync to ON
- Very important! Check your monitor settings (usually using the hardware buttons on the device) and make sure the monitor itself is running at 60Hz as well! If it's not, the physics may still bug out.

I remember having similar issues with Assassins Creed 2. The physics sometimes bug out when you run these games at anything over 60Hz

10-29-2019, 03:29 PM
It's such a shame.. the game was developed quite a while ago and they still haven't fixed this bug

10-30-2019, 12:41 AM

Have you tried restarting the mission? This helps a lot of times when you encounter a weird bug.