PDA

View Full Version : Cant get some gfx settings with nvidia



Fish44
03-30-2009, 12:42 PM
Using OpenGL, but cant get landscape lighting and detail to highest. They are greyed out.

I got an 8800ultra, with latest drivers.

Thanks

Fish44
03-30-2009, 12:42 PM
Using OpenGL, but cant get landscape lighting and detail to highest. They are greyed out.

I got an 8800ultra, with latest drivers.

Thanks

FoolTrottel
03-30-2009, 12:46 PM
In Nvidia's control panel, set 'Extension Limit' to Off...

Fish44
03-30-2009, 03:03 PM
Thanks but extension limit is alread 'off'.

Urufu_Shinjiro
03-30-2009, 04:19 PM
Hmm, post a copy of your conf.ini.

alphalvr
03-30-2009, 04:38 PM
i have a post on this page with similar problem....its just falling from view..... so i to would like to know wots going on.

my post
http://forums.ubi.com/eve/foru...3110283/m/2161081547 (http://forums.ubi.com/eve/forums/a/tpc/f/23110283/m/2161081547)

my config ini

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=0

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=2
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3
Water=1
Effects=2
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0


i keep setting `hardware shaders to 1` and in game i then see the options `perfect` and `excelent` as extra options 4 2 selections (see my post) but they are greyed out and cant be selected

when i next look at config ini `hardware shader` is back at `0`

i also added a line under {game} which was suppposed to give special (detailed?) clouds but that to has vanished??

running 4.08m 1942

p4 3ghz
3 gig ram
agp 512mb 7900gs
fatality creative sound (the best one with the onboard ram and i/o control panel)

ps using open gl, i believe that is the best??

i notice it gives me a different video card id for open gl/directx?

should i choose a different video id, i belive there was a custom one one upon a time?



heres thee rest of the config file, just in case its needed.... sorry for mega post

[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1280
height=960
ColourBits=32
DepthBits=24
StencilBits=0
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=1
Use3Renders=0

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=5000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=
localHost=
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.6925,dy=0.071666665,x=0.0,y=0.0)

[game]
Arcade=0
HighGore=0
mapPadX=0.66875
mapPadY=-0.046875
viewSet=33
Intro=1
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1


[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=4
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=6
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=1
MasterVolume=14
Attenuation=7
SoundMode=3
SamplingRate=2
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=12
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=1
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=1
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
;ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=1
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 10 20 30 40 50 60 70 80 90 100 0
1Y=0 10 20 30 40 50 60 70 80 90 100 0
1Z=0 100 100 100 100 100 100 100 100 100 100 0
1RZ=0 100 100 100 100 100 100 100 100 100 100 0

ElAurens
03-30-2009, 09:22 PM
Change hardware shaders to 1.

Water=4.

alphalvr
03-31-2009, 07:44 AM
u missed the bit where i said i do change it to 1, then i see the perfect option, but its greyed out.

next timei restrat if i look at config file hardware shaders is back at 0 http://forums.ubi.com/images/smilies/16x16_smiley-mad.gif

edit

unless water 4 is a necessary change??? and thats what your saying im doing wrong??

alphalvr
03-31-2009, 07:57 AM
ok i sorted it by findind a oolder post/

1st i went into game and set stencil buffer to on (red light comes on)

then i selected hardware shaders 1 in config file (after shutting down game)

restarted and now perfect is not only a option is already selected and not greyed out.

now all i need is to find how far each setting can go.

water 4 for instance

Urufu_Shinjiro
03-31-2009, 09:55 AM
Wow, nice hijack, well, I'm glad you got your problem fixed, now maybe Fish44 can...

alphalvr
03-31-2009, 02:27 PM
hope i did nothing wrong, good luck to him.

his family never even payed the ransom http://forums.ubi.com/images/smilies/blush.gif

i give yo permission to merge my post, to tidy things up and so i dont feel so quilty about it all http://forums.ubi.com/images/smilies/11.gif