PDA

View Full Version : Saitek X52 users try old drivers



theigthorn
03-26-2009, 08:31 PM
We've did some testing with older drivers and it doesn't crash the game when loading. Remove all Saitek drivers and software that you have installed, then install the old drivers to see if it fixes the issue.

I can't find the exact drivers used on the web but try these out, we used the ones that came with the joystick (Oct 2004).

http://driverscollection.com/?...itek&SS=Windows%20XP (http://driverscollection.com/?H=X52&By=Saitek&SS=Windows%20XP)

theigthorn
03-26-2009, 08:31 PM
We've did some testing with older drivers and it doesn't crash the game when loading. Remove all Saitek drivers and software that you have installed, then install the old drivers to see if it fixes the issue.

I can't find the exact drivers used on the web but try these out, we used the ones that came with the joystick (Oct 2004).

http://driverscollection.com/?...itek&SS=Windows%20XP (http://driverscollection.com/?H=X52&By=Saitek&SS=Windows%20XP)

LT.INSTG8R
03-27-2009, 03:58 AM
Actually Steam updated HAWX today and YAY I can finally use my X-52 without issue(okay of course there is the Deadzone issue still) but I am using the latest ones(I believe they are from Feb of this year)

CircusMidget_TS
03-27-2009, 10:22 AM
Hey guys, thanks for providing this information. Can anyone else confirm this has helped them?

Gypsy816
04-01-2009, 02:23 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by CircusMidget_TS:
Hey guys, thanks for providing this information. Can anyone else confirm this has helped them? </div></BLOCKQUOTE>

Yes please post if this helps with the Saitek X52 so I can report back on the results. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif