PDA

View Full Version : Need help with BIGproblem _Can't run OpenGL anymore



peterm1
05-21-2005, 12:34 AM
I usually run FB under OGL as it gives a major performance boost on my machine. I only have a thinkpad which limits me a bit but I have used it successfully for the past 2-3 years to run FB and its predecessors.

When I fired up today the game virtually hung at the first screen after loading. (ie It was not quite a hang as if I moved the mouse, the cursor would sort of move about 15 seconds later.) I closed out and tried to run it under Direct X and there it is business as usual - runs ok but not optimal as I would expect. I repeated this on many occasions with the same result. Also I found that some OpenGL settings in the FB Set up menu do not save or at least they revert after I load the game.

So after trying everything i could think of for a day i eventually decided that the problem was the OpenGL drivers for the ATI Radeon. (I tried reinstalling the latest Omega driver which was and still is functioning fine, so I figure it cannot be that.)

The driver file referenced by the system is opengl32.dll so i did a search on my system (and later specifically in the windows/system directory which is where this belongs) and sure enough it is missing. Perhaps something happened when I used a utility to clean up my registry recently??????

So I have downloaded the file from the internet and installed it but got the same reaction when I ran the game. Possibly other related dll files are also missing..

I am hoping someone has some ideas that cna help. Either as to what the problem is and how to fix it or perhaps, best of all, a place where I can D/L the whole set of OpenGL drivers. I had a look at the ATI site but could not locate them there....... HELP

peterm1
05-21-2005, 12:34 AM
I usually run FB under OGL as it gives a major performance boost on my machine. I only have a thinkpad which limits me a bit but I have used it successfully for the past 2-3 years to run FB and its predecessors.

When I fired up today the game virtually hung at the first screen after loading. (ie It was not quite a hang as if I moved the mouse, the cursor would sort of move about 15 seconds later.) I closed out and tried to run it under Direct X and there it is business as usual - runs ok but not optimal as I would expect. I repeated this on many occasions with the same result. Also I found that some OpenGL settings in the FB Set up menu do not save or at least they revert after I load the game.

So after trying everything i could think of for a day i eventually decided that the problem was the OpenGL drivers for the ATI Radeon. (I tried reinstalling the latest Omega driver which was and still is functioning fine, so I figure it cannot be that.)

The driver file referenced by the system is opengl32.dll so i did a search on my system (and later specifically in the windows/system directory which is where this belongs) and sure enough it is missing. Perhaps something happened when I used a utility to clean up my registry recently??????

So I have downloaded the file from the internet and installed it but got the same reaction when I ran the game. Possibly other related dll files are also missing..

I am hoping someone has some ideas that cna help. Either as to what the problem is and how to fix it or perhaps, best of all, a place where I can D/L the whole set of OpenGL drivers. I had a look at the ATI site but could not locate them there....... HELP

peterm1
05-21-2005, 12:39 AM
OOPs Sorry I somehow posted this on the general forum I will move it to tech support.