PDA

View Full Version : Revelations not optimized for PC?



NICK.ALTMAN
12-19-2011, 12:23 PM
Well I ve been playing for a week now and with my PC i7 870, GTX 560 Ti, 8GB Ram, Win 7 and I am expiriencing lag in Constantinople. I keep my settings the same as in Brotherhood where I had no lag. My settings are;
Multisampling OFF
Vsynch ON
Enviorment 4
Texture 3
Shadow 3
Reflection Medium
Character 3
Post-Effects ON

So its rather medium settings. Game works at 60 FPS without lag. But I enter the main Assassins HQ game lages and FPS drop to 45-50. When I walk the streets its ok. I get to the roofs take a look towards Imperial part of Constantinole from Galata FPS drops to 40, and lags. In Grand Bazar when there is a crowd FPS drops to 45. So it seems they rushed the PC version and didn't optimize the game. I hope there will be a patch for better performance.

iNvid22
12-19-2011, 12:39 PM
yeah there are quite a few places where the fps drops, the port being one. nothing you can do, lowering your settings doesn't help.

just adjust the settings so you can get a steady 60 most of the time.

previous ports have been solid, ACR is still decent but the 1 year cycle starts to show

spectatorx
12-19-2011, 12:56 PM
IMO revelations is best optimised ac game so far. I do not have fps drops as you described.

Try to disable in motherboard bios hyperthreading and let know if that helped. Hyperthreading in i3, i5 and i7 cpus is causing in some games various problems.

NICK.ALTMAN
12-19-2011, 01:22 PM
Originally posted by spectatorx:
IMO revelations is best optimised ac game so far. I do not have fps drops as you described.

Try to disable in motherboard bios hyperthreading and let know if that helped. Hyperthreading in i3, i5 and i7 cpus is causing in some games various problems.

How do I do that? Please describe.

spectatorx
12-19-2011, 01:49 PM
It is described in your motherboard's manual. Look in bios for phrase multithreading and set it to disabled.

SixKeys
12-19-2011, 08:20 PM
The only place I continuously experience lag in singleplayer is whenever I'm in the assassin hideout. I have a very good graphics card and the game works fine in all other locations, but for some reason the hideout makes the game jerky.

illincrux
12-19-2011, 10:23 PM
pfft, you guys are seriously moronic.

Don't disable hyperthreading unless you want to go back to the stone ages.

It's the engineer's fault if he can't get hyperthreading to work correctly and forcing you to disable it is like smashing in your own knee caps.

NICK.ALTMAN
12-20-2011, 02:17 AM
Originally posted by illincrux:
pfft, you guys are seriously moronic.

Don't disable hyperthreading unless you want to go back to the stone ages.

It's the engineer's fault if he can't get hyperthreading to work correctly and forcing you to disable it is like smashing in your own knee caps.

I agree. The game has been engniered badly. I also find disabling anything so stupid.

NICK.ALTMAN
12-20-2011, 02:18 AM
Originally posted by SixKeys:
The only place I continuously experience lag in singleplayer is whenever I'm in the assassin hideout. I have a very good graphics card and the game works fine in all other locations, but for some reason the hideout makes the game jerky.

Can you tell me your specs?

And I agree the assassin hideout is the laggiest place in the game.

Vey03
12-20-2011, 03:14 AM
I'm no computer tech, but i don't feel the game is.

The hideout is the worst part of the game, yes. And it's really the only area i get anything.

The other bit is stuttering here and there, and it's almost always when i'm auto-walking with people. Eg, when you walk with your recruit, or follow someone and Ezio auto-walks with them... those parts are always glitchy.
I'm running my game with everything on and maxed.
Frame rate, I average anywhere between 20-60fps, and it really makes not much difference where i am in the game, and what they drop to, overall the gameplay is smooth-ish.

value_zero
12-20-2011, 03:20 AM
Originally posted by illincrux:
pfft, you guys are seriously moronic.

Don't disable hyperthreading unless you want to go back to the stone ages.

It's the engineer's fault if he can't get hyperthreading to work correctly and forcing you to disable it is like smashing in your own knee caps.

I agree with that, I have a dual core gpu, ive disabled one specificly for one game, i did this on beta driver of the gpu and now the second core is faulty and windows doesnt detect it at all. I did this trough nvidia control panel, imagine what would happen if you do changes in the bios.

spectatorx
12-20-2011, 05:25 AM
Originally posted by value_zero:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by illincrux:
pfft, you guys are seriously moronic.

Don't disable hyperthreading unless you want to go back to the stone ages.

It's the engineer's fault if he can't get hyperthreading to work correctly and forcing you to disable it is like smashing in your own knee caps.

I agree with that, I have a dual core gpu, ive disabled one specificly for one game, i did this on beta driver of the gpu and now the second core is faulty and windows doesnt detect it at all. I did this trough nvidia control panel, imagine what would happen if you do changes in the bios. </div></BLOCKQUOTE>


WTF?! Are you sure what you are talking about? Hyperthreading has nothing to do with nvidia control panel and you can't disable it via nvidia control panel and you can't disable physical cores by disabling hyperthreading, by doing this you are disabling only logical cores.


Hyperthreading is from stone age ;-) I had it with pentium 4 cpu and with these cpus it was working fine, now i see intell is using this technology again but as i've read at many forums in many cases it is causing various issues in games.

value_zero
12-20-2011, 05:37 AM
Originally posted by spectatorx:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by value_zero:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by illincrux:
pfft, you guys are seriously moronic.

Don't disable hyperthreading unless you want to go back to the stone ages.

It's the engineer's fault if he can't get hyperthreading to work correctly and forcing you to disable it is like smashing in your own knee caps.

I agree with that, I have a dual core gpu, ive disabled one specificly for one game, i did this on beta driver of the gpu and now the second core is faulty and windows doesnt detect it at all. I did this trough nvidia control panel, imagine what would happen if you do changes in the bios. </div></BLOCKQUOTE>


WTF?! Are you sure what you are talking about? Hyperthreading has nothing to do with nvidia control panel and you can't disable it via nvidia control panel and you can't disable physical cores by disabling hyperthreading, by doing this you are disabling only logical cores.


Hyperthreading is from stone age ;-) I had it with pentium 4 cpu and with these cpus it was working fine, now i see intell is using this technology again but as i've read at many forums in many cases it is causing various issues in games. </div></BLOCKQUOTE>

I was giving an example for not messing with the hardware 0.o, think a little, aint gonna hurt.

spectatorx
12-20-2011, 05:43 AM
So that was bad example which can mislead someone who need help and it may be a fix to this person's problem... think a little, aint gonna hurt.

value_zero
12-20-2011, 05:46 AM
And still you are pointing a guy towards the bios, who has no idea about working with it, even if you explained, without consulting with someone in person he can make the things even worse http://forums.ubi.com/images/smilies/clap.gif


can mislead someone who need help and it may be a fix to this person's problem

Do you seriously think someone is that stupid to do that, or even have dual gpu card, when the only nvidia multi gpu cards i can think of are gtx 295 and gtx 590, and 295 is no longer out for sale, and gtx 590 is used by enthusiasts who have a bright idea what they are doing, so thats the second think that cant possibly mislead someone.

p.s.- i will lower the lath of the average iq in this forum in my future posts, so guys like you can understand better.

spectatorx
12-20-2011, 06:04 AM
Hm.. Disabling one optional thing is nothing what can make your computer crash, setting one option in bios is not so hard, do not exaggerate, pls.

Changing bios setting is hard and can make computer do not work... IT IS A MYTH!!! if you can read... and as i can see all people in here can read.

value_zero
12-20-2011, 06:40 AM
You didnt exaggerate about the gpu, right, riiiight, so about the bios, it is a myth, overclocking your cpu with the unproper cooling, will not cause your pc crash even to not work, great math mate http://forums.ubi.com/images/smilies/25.gif. Please return to your planet.

spectatorx
12-20-2011, 06:42 AM
I didn't say a word about overclocking, or did i...

value_zero
12-20-2011, 06:45 AM
Its configurated in BIOS, oh god, why, why did you send me here? (headbang)

spectatorx
12-20-2011, 06:48 AM
Yes, overclocking is configurable in bios but it is optional and you do not have to do this, i said a tip about changing one option in bios and specified this one option, changing this one exact option will not make your motherboard blow up.

@value_zero, have you ever seen bios? :-)

value_zero
12-20-2011, 06:53 AM
There are diffrent variations of BIOSes, there are stupid people who mess the things up, that is not described in the manual you are reading right now


@value_zero, have you ever seen bios? :-)

You didnt light your brain about the OC in the bios at first, dude you see that you are losing this argument and try to splash the things.

spectatorx
12-20-2011, 07:00 AM
I see you never seen bios and have no idea how it works so it makes i have nothing to talk more about it with you. ;-)

Overclocking is one thing, disabling hyperthreading, pressing f10 key and accepting settings by pressing enter key on yes is separate thing.

value_zero
12-20-2011, 07:07 AM
I assume you didnt read at least one book in your whole life, since you cant understand what i was talking about, and i lost enough brain cells just to be in conversation with you. OC features are located in BIOS, now go to your friends and share what you have learned today, i assume you sleep with your monitor on BIOS screen, since its your soft spot.

spectatorx
12-20-2011, 07:15 AM
I agree with you oc setting are in bios but by entering the bios you do not have to change them, you can leave them as they are so what is unsafe in disabling hyperthreading in bios? Tell me, pls 'cos i really do not understand how it would blow up machine.

value_zero
12-20-2011, 07:18 AM
Ok, lowering the lath of the average iq, even more, i explain it in one of the previous posts, you cant be that dumb, y n?

- Even if they use manual to act accordingly troughout, there are people dumb enough to mess it.
- Even if he did it the right way, there is always risk, like the example i gave (its a machine after all),
- You tought it is safer to work with bios, than with for instance nvidia control panel.

spectatorx
12-20-2011, 07:23 AM
Ok, you can call me dumb but it didn't change status quo, you really need to get some knowledge about. I will not answer anymore to any of your messages, on forum or private ones until you will get bit knowledge about how bios works ;-)

value_zero
12-20-2011, 07:24 AM
Ok, you can call me dumb

Ok go take a pillow and angle in the room and cry about it.

NICK.ALTMAN
12-20-2011, 08:24 AM
So you both agree game is not well optimized?

spectatorx
12-20-2011, 10:37 AM
IMO the game is much better optimized than assassin's creed 2 and brotherhood.