PDA

View Full Version : Oleg: Will FB, AEP, etc. work with XP SP2?



arjisme
03-08-2004, 09:22 PM
Oleg, I am sure you are aware that Microsoft plan to release SP2 for Windows XP sometime this year. This SP will possibly break some existing applications because they are recompiling the OS to have enhanced memory protection. My question is: do you have plans to test and, if necessary, modify FB, AEP, and other IL-2 titles to ensure they will work under this service pack? It will be a disaster if folks upgrade via Windows Update and then find they can no longer fly!

arjisme
03-08-2004, 09:22 PM
Oleg, I am sure you are aware that Microsoft plan to release SP2 for Windows XP sometime this year. This SP will possibly break some existing applications because they are recompiling the OS to have enhanced memory protection. My question is: do you have plans to test and, if necessary, modify FB, AEP, and other IL-2 titles to ensure they will work under this service pack? It will be a disaster if folks upgrade via Windows Update and then find they can no longer fly!

Mave_FI
03-08-2004, 11:52 PM
Format C: and reinstall Windows
.
.
.
or
.
.
.
Try that System Restore thingy, I think that's exactly the reason why it's there in XP anyway http://ubbxforums.ubi.com/infopop/emoticons/icon_smile.gif

IL-2 will for sure have some kind of patch to make it work with SP2 if that happens...

Mave / Lufthunden
www.lufthunden.com (http://www.lufthunden.com)

Stalker58
03-09-2004, 05:22 AM
Don't install SP2! http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

Altitude, speed, manoeuvre and.... CRASH!

arjisme
03-09-2004, 07:32 AM
Reformatting & reinstalling or using system restore won't be an option. The OS won't be broken. In fact, it will be better since security will be much improved. Not installing SP2 won't be an option either. Many new customers will already have it on their system when they buy future products (BOB?). Also, in order to continue to apply updates, you will need to keep a current patch level. So, Mave_FI, I hope you are right that they will make a patch if needed to keep things working under SP2.

tolwyn.com
03-09-2004, 12:30 PM
Then perhaps playing FB "won't be an option" either if you go to SP2.

Just saying.

arjisme
03-09-2004, 12:55 PM
Well, I think that is pretty obvious, thus this thread. It won't just be my problem, though. It will be Oleg's too. The market for this product will shrink if it can't run on MS's current consumer-based OS. I can't see a downside to thinking ahead and trying to be prepared for future changes.

VW-IceFire
03-09-2004, 01:08 PM
I really hope that SP2 doesn't break compatibility with some older games. In theory it shouldn't but I do worry.

FB should be fine...in theory http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

I'm sure there will be some problems. There always are.

http://home.cogeco.ca/~cczerneda/sigs/temp_sig1.jpg
RCAF 412 Falcon Squadron - "Swift to Avenge"

Agamemnon22
03-09-2004, 02:19 PM
I don't see why it would be a problem, IL2 is not unique in any way that I know. It's a program that talks to the OS to do whatever it does. At no point is it concerned with how the OS goes about doing it.

tolwyn.com
03-09-2004, 02:36 PM
I was kinda being ornery.

I can't imagine what part of IL2's code would be affected by SP2. The only caveat would surround something in their utilization of Java.

I wouldn't worry that much.