View Full Version : Disc 1 wont eject on installation

10-23-2004, 09:58 PM
I can't seem to find another discussion of this problem, so here goes.

MystIV installs OK until it is time to insert disc 2. Disc 1 doesn't automatically eject, and I can't manually eject - even dragging it to the trash doesn't work.

I'm using OSX 10.2.8 and running a G4. Drive is a Pioneer DVR107d.

Any clever person out there know what's going on?

10-23-2004, 10:00 PM
PS There is no Mac firmware upgrade for the drive, so that's not an option.

10-24-2004, 12:14 AM
Yup, known mac issue. Supposedly something that may or may not be fixed in a patch. Nobody is really sure what causes it.

Apparently if you drag and drop the CD to the trash it'll eject it... Or, on those other rare cases, wait about 10 minutes.. and then try to drag and eject.

Or hold down F12 and see if that works.

Very strange problem, don't know if anyone here has a good answer.

10-24-2004, 01:48 AM
Well, who knows why, but waiting 10 minutes, drag and drop works perfectly. Thank you.

10-24-2004, 03:15 PM
Welcome, sorry you had issues with that -- I'm not sure what causes it either http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

10-25-2004, 08:45 PM
The one time I managed to get my disc 1 to eject, I clicked onto the desktop to make Finder active, then dragged the disk to the trash. It could have been coincidence, but out of the 4 or 5 times I tried to install, that was the only time it worked.

10-25-2004, 10:13 PM
I'm wondering if the installer is failing to stop using the disk immediately, causing the Mac to hang onto it until all running programs leave that mounted volume.

If anyone else encounters this (or wants to play with it) and has a bit of Unix knowledge.. You may want to try to unmount the drive manually and see what that does for you. I haven't tried unmounting a CD Drive on a Mac manually, so no clue what will happen if you try it...

12-26-2004, 12:16 PM
I had this problem and managed to solve it. I held down the "option" key and then pressed the "eject" key and it worked.

12-29-2004, 08:51 PM
I have the same computer, garethf, and have tried all of these suggestions. Still no luck. And now I have quit trying. Too much stress.