PDA

View Full Version : X-52 Issue



maglor1981
09-27-2008, 06:38 PM
The problem I'm facing is that I have connected X52 joystick and a gamepad to my PC IL-2 sees only the gamepad and I have to manually configure to acceptX52.

How can I select to automatically use X52 joystick.

Also the game has problems with the fact that the controller has more than the standard 4 axes and insists on only seeing the precision slider on the throttle unit as being the throttle instead

maglor1981
09-27-2008, 06:38 PM
The problem I'm facing is that I have connected X52 joystick and a gamepad to my PC IL-2 sees only the gamepad and I have to manually configure to acceptX52.

How can I select to automatically use X52 joystick.

Also the game has problems with the fact that the controller has more than the standard 4 axes and insists on only seeing the precision slider on the throttle unit as being the throttle instead

DD_crash
09-28-2008, 02:02 PM
Hello, please read this (http://www.airwarfare.com/tech/sticks.htm) and the nuggets guide. Its all you need http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

K_Freddie
09-28-2008, 04:26 PM
This sounds like a IL2 detection problem with regard to USB.

The Gamepad (I think) uses the same HID (Human/Hardware Interface Device) as a joystick, so has priority over the X52.

This might be because you connected the Gamepad first. Pull both out and then connect the X52 first - see what happens. If it's still a problem, leave the Gamepad disconnected - this should work OK with IL2.

I don't bother with the Saitek config/installation software, as it introduces more overhead/delays/problems with games. Just connecting the X52, windozeXP will detect it, as XP has an USB enumeration(number counter) device driver. IL2 uses this to determine what HIDs/toys are connected.

http://forums.ubi.com/groupee_common/emoticons/icon_cool.gif

Urufu_Shinjiro
09-28-2008, 06:28 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by K_Freddie:
This sounds like a IL2 detection problem with regard to USB.

The Gamepad (I think) uses the same HID (Human/Hardware Interface Device) as a joystick, so has priority over the X52.

This might be because you connected the Gamepad first. Pull both out and then connect the X52 first - see what happens. If it's still a problem, leave the Gamepad disconnected - this should work OK with IL2.

I don't bother with the Saitek config/installation software, as it introduces more overhead/delays/problems with games. Just connecting the X52, windozeXP will detect it, as XP has an USB enumeration(number counter) device driver. IL2 uses this to determine what HIDs/toys are connected.

http://forums.ubi.com/groupee_common/emoticons/icon_cool.gif </div></BLOCKQUOTE>

Or you could read the link DD_Crash posted and learn the proper solution yourself, lol.

K_Freddie
09-29-2008, 01:48 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Urufu_Shinjiro:
Or you could read the link DD_Crash posted and learn the proper solution yourself, lol. </div></BLOCKQUOTE>

errr.. I did read it sometime ago, hence my extra bit of info on USB stuff. http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

Aaron_GT
09-29-2008, 02:04 AM
Advanced warning: I will move this thread to Community Help tomorrow.